Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Applications crashing/not opening

  1. #1

    Default Applications crashing/not opening

    Recently I changed operating systems to openSUSE 11.0 from OS X 10.3.9. For the first three weeks of openSUSE, I had no problems with applications opening correctly or crashing when used. In the past week though, many applications will not open, or will crash within moments of being opened. An example of this with Kopete: I have been in the middle of a conversation and it just crashed. After a few tries to open it, it would open briefly, then crash again. I think the problem might have to do with how some packages are installed. This isn't localized to Kopete. Any insight, or any way I could further define this to help would be greatly appreciated.
    I'm running 11.0 and KDE 3.5
    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Applications crashing/not opening

    And you are not receiving a crash report?

    Try running an application from a terminal. Open a terminal and type: kopete or whatever app it is.
    Errors will be reported in the terminal output. Post them here.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2009
    Location
    Holland
    Posts
    47

    Default Re: Applications crashing/not opening

    And if you want a new messenger, aMSN is a very good instant Messenger.
    Coffee is like Linux, only cool people use it. Tea is like Windows, only losers use it.

  4. #4

    Default Re: Applications crashing/not opening

    I've rebooted a couple times, and its seems to help with some programs, but after a program crashed and displayed an error message, I ran a backtrace.
    The backtrace message said:
    "This backtrace appears to be of no use.
    This is probably because your packages were built in a way that prevents the creation of proper backtraces, or the stack frame was seriously corrupted."
    I'm thinking the problem is how the packages were built. What should I do to rebuild them so that they aren't a problem?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Applications crashing/not opening

    As I said earlier:

    Try running an application from a terminal. Open a terminal and type: kopete or whatever app it is.
    Errors will be reported in the terminal output. Post them here.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Applications crashing/not opening

    xxxxxxx@linux-lzy1:~> opera
    ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
    NPP_GetValue()
    NPP_GetValue()
    NPP_GetValue()
    Segmentation fault
    xxxxxxx@linux-lzy1:~>

    Thats the problem with opera.
    I think this might be different than before since its specific to opera, manifests itself slightly differently, and I removed almost all of the packages that I added on.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Applications crashing/not opening

    Please see that your java packages are like this

    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Applications crashing/not opening

    What repositories are you using?
    I don't have all of the Java packages that you do.
    Here is a link to a screenshot of my package manager.


  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Applications crashing/not opening

    Please open a terminal and do

    Code:
    zypper lr --details
    Post result
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Applications crashing/not opening

    xxxxxxx@linux-lzy1:~> zypper lr --details
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI
    ---+---------------------------+---------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------
    1 | openSUSE-11.0-FTP 11.0 | openSUSE-11.0-FTP 11.0 | Yes | Yes | 99 | yast2 | Index of /distribution/11.0/repo/oss
    2 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/non-oss
    3 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | http://suse.linuxin.dk/repo/11.0/
    4 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.0
    5 | Java:jpackage-1.7 | Java:jpackage-1.7 | Yes | Yes | 99 | rpm-md | Index of /repositories/Java:/jpackage-1.7/openSUSE_11.0
    6 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes | 99 | rpm-md | Index of /distribution/11.0/repo/non-oss/suse
    7 | repo-oss | openSUSE-11.0-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/oss
    8 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes | 20 | rpm-md | Index of /update/11.0
    9 | repo-debug | openSUSE-11.0-Debug | No | No | 120 | NONE | Index of /distribution/11.0/repo/debug
    10 | Main Repository (OSS) | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.0/repo/oss

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •