Results 1 to 5 of 5

Thread: Wrong Digest - can't add repository or update

  1. #1

    Default Wrong Digest - can't add repository or update

    Hello

    Since yesterday (at least that's when I noticed) either updating or adding repository is not working. When I run online update, it gives warning "Wrong Digest" and also gives following warning.

    There was an error in the repository initialization.
    'openSUSE-11.1-Updates': [|] Failed to cache repo (4).
    History:
    - 'repo2solv.sh' '-o' '/var/cache/zypp/solv/openSUSE-11.1-Updates/solv' '/var/cache/zypp/raw/openSUSE-11.1-Updates'

    gzip: primary.xml.gz: not in gzip format

    gzip: susedata.xml.gz: not in gzip format

    gzip: updateinfo.xml.gz: not in gzip format
    repo_updateinfoxml: no element found at line 1:0

    Thanks in advance.

    Woojin

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Wrong Digest - can't add repository or update

    Try this first:
    Open a terminal and go su and do:

    Code:
    rpmdb --rebuilddb
    It may help. Come back if it doesn't.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Wrong Digest - can't add repository or update

    Hello.

    I removed all repositories in yast2 and did "rpmdb --rebuilddb".
    Then I added the 11.1 oss repo by issuing following command.
    "zypper addrepo Index of /distribution/11.1/repo/oss oss"

    Then when I try to refresh by "zypper ref"
    I get the following wrong digest error
    "Digest verification failed for dvd-11.1-71.1.i586.pat.gz. Expected 1e69c0fe3c858c38e01668372207c21cd8a7daa5, found 4a59fcad0e70adfe7eeb4e2b968b7bad3280755d. Continue? [yes/NO]:"

    I get same error for any repo I try to add.

    Thanks in advance.

    Woojin

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Wrong Digest - can't add repository or update

    Let's clear the repo's and add them in this way. Here are some guides
    Repository Management - openSUSE Forums

    carl4926 - Adding Repo in Yast
    --------------------------------------------------------------------
    add in these URL's

    OSS
    Index of /distribution/11.1/repo/oss

    NON-OSS
    Index of /distribution/11.1/repo/non-oss

    UPDATE
    Index of /update/11.1
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Wrong Digest - can't add repository or update

    I found the problem.
    I had enabled the systemwide proxy using squid and dansguardian. That must have caused some sort of conflict. Disabling the system proxy fixed the issue.

    Thanks for your help.

    Woojin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •