Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: No video after updates.

  1. #1
    Join Date
    Sep 2008
    Location
    Port Saint Lucie, FL
    Posts
    46

    Default No video after updates.

    Hello all,

    I have no video.

    When I boot up, I get a splash screen and the progress bar gets almost done. But when the desktop should appear, the screen goes blank.

    Last thing that was done was a couple of updates loaded.

    any command I can use at a prompt, so I can get to the desktop?

    ver 11.1 kde

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No video after updates.

    There was an update 1 or 2 weeks ago of the X11 applications, and then a day ago there was an update of the kernel, either of which can break your GUI if you were using a proprietary ATI or nVidia driver.

    You could try booting to run level 3 (do that by typing "3" (no quotes) in the grub boot menu options line, where you choose windows, or openSUSE, or safe setting to boot) and that will boot to an ascii/text login. Log in with your regular user name and password.

    Once logged in type "su" (no quotes) to get root permissions (enter root password)

    Then back up your /etc/X11/xorg.conf file with:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backupnew
    then as an iterim, try configuring to run with the VESA graphic driver using sax2:
    sax2 -r -m 0=vesa
    when that completes and you are back at a prompt, reboot and see if it works this time. You can reboot by typing:
    shutdown -r now

    if that works, then you need to read up on installing an updated proprietary driver :

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: No video after updates.

    Try failsafe first from the boot menu. It should get you to some sort of graphical desktop. Then look at re-installing graphics driver. If failsafe doesn't work you can try switching to vesa graphics like this:

    Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=...etc
    Remove all text and now type just the number:
    3
    and hit enter

    at the login type your user name and then password
    now type:
    su
    then the root password

    now type this:
    sax2 -r -m 0=vesa
    (N.B. the 0 is a zero not a letter)
    now reboot- type: reboot
    if you don't get a gui login
    login as user at cli and try this at the cli
    startx
    [edit] sorry to overlap Lee!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Sep 2008
    Location
    Port Saint Lucie, FL
    Posts
    46

    Default Re: No video after updates.

    OK,

    I'll give it a shot. I am using an ATI card by the way.

    radeon x300 128meg

    John

  5. #5
    Join Date
    Sep 2008
    Location
    Port Saint Lucie, FL
    Posts
    46

    Default Re: No video after updates.

    OK,

    I backed up the conf file and typed sax2 -r -m 0=vesa as instucted. But this is what I got:
    ___________________________________________
    sax:initializing Please wait
    sax:Your current configuration will not in

    Sax:no x-server is running
    sax:will start own server if needed
    "spp:"prepare device [0] profile.addon
    (1)sax:

    ___________________________________________

    This looks like a line editor to me. I did not get back to a prompt. I typed exit and got back to a garbled screen that looked like the boot loader.

    Rebooting did not fix the problem. Still getting a blank screen.

  6. #6

    Default Re: No video after updates.

    iwadmin,

    There was a Kernel Update yesterday, which means if you installed the proprietary graphics driver from ATI, you will need to re-run the installer, to rebuild the kernel module.If you have a copy of the package, login to the system via console. SU to root, and run "init 3" to put the system in runlevel 3. Then install the graphics driver, when it's done, init 5 to switch back to runlevel 5, and you should be back in your DE.

    Sincerely
    Mark Brown

  7. #7
    Join Date
    Sep 2008
    Location
    Port Saint Lucie, FL
    Posts
    46

    Default Re: No video after updates.

    install the driver from the prompt or will runlevel 3 get me graphical?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No video after updates.

    Quote Originally Posted by iwadmin View Post
    I backed up the conf file and typed sax2 -r -m 0=vesa as instucted. But this is what I got:.
    If you can recall how to rebuild the ati driver, that is probably the best approach.

    Still there are other sax2 options you can try with the vesa driver. For example you could try without the "-r" option:
    sax2 -m 0=vesa

    or try a low resolution:
    sax2 -l -m 0=vesa
    (where -l is a lowercase "L" for "Low Resolution")

  9. #9
    Join Date
    Sep 2008
    Location
    Port Saint Lucie, FL
    Posts
    46

    Default Re: No video after updates.

    Well, this is a new install, I guess I could reinstall and not enable the ATI repository.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No video after updates.

    Quote Originally Posted by iwadmin View Post
    Well, this is a new install, I guess I could reinstall and not enable the ATI repository.
    or simply remove the rpm that you installed as part of the ATI driver. What is the output of:
    rpm -qa | grep fglrx

    I suspect if that shows an application installed, one can remove it, and then the sax2 commands would work. ...

    Also, what is the output of:
    sax2 -p

    ... if the fglrx rpm is removed, then sax2 commands you could try are:
    sax2 -r -m 0=vesa
    or
    sax2 -r -m 0=ati
    or
    sax2 -r -m 0=radeon
    or
    sax2 -r -m 0=radeonhd

    ... or simply re-install/build the ATI driver. I provided the link previous: ATI - openSUSE

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •