Results 1 to 5 of 5

Thread: Java heap space not reserved

  1. #1

    Default Java heap space not reserved

    I did a clean install of SUSE 11.1 and brought it up-to-date. This is as a VMWare virtual machine on my Mac OS 10.5.7 system.

    Java isn't working and even after a restart. When I type the following into the terminal window I get:

    kimball@linux-2hwv:~> java -version
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.


    Chris Kimball
    mail@cvkimball.xom

  2. #2

    Default Re: Java heap space not reserved

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    How much RAM did you give the box? Does it work as 'root' or some other user?

    Good luck.





    christopherkimball wrote:
    > I did a clean install of SUSE 11.1 and brought it up-to-date. This is
    > as a VMWare virtual machine on my Mac OS 10.5.7 system.
    >
    > Java isn't working and even after a restart. When I type the following
    > into the terminal window I get:
    >
    > kimball@linux-2hwv:~> java -version
    > Error occurred during initialization of VM
    > Could not reserve enough space for object heap
    > Could not create the Java virtual machine.
    >
    >
    > Chris Kimball
    > mail@cvkimball.xom
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKaLn7AAoJEF+XTK08PnB5y/YQAMIQYlsOYoDr6oj43SR9xWYN
    twQKndnZdDl3t5BdHM56Y17orjF9QNbQczzoiI9k0QUCVUtSKkodPqJcHLl8S0x7
    FZzuaFN5qBCGbkHPu5fwn/eHsuwdQq5PaVrCG0IGEOL+/vkUiA8LhfVEYumvPei0
    isyufcgREs9UP2KqcNlovpZDFzf7WTKpIL9fWHW4hUEc169BdEvdCvyxGqXbs4jI
    35dj7/sFdh0GyADVcDFYX2ktMlaLGK1HGlSFZAZVzxruC7rUO2Hlw7TGlQbNyMp3
    sd/Q3A/DJk4ZJq6bOm90yXEHYpTsINjG60Ytl0+Wyj29J1wYQ1948+2nort4WGQg
    AbIvMpzb/XgEI2xhv2ZMxOzhVWW/kYV/fthbuEcQBEv8WchW6wpKl9roE3Ce+5RE
    kbZj5xPnWyOcWvtye7ZgSO2rXPPEkC9A/8+Mecp8sFQsY1Zlq1jXWfCtpCAQnVJO
    xN8azKJI9gl56B6GEKzN5k/S5hIUyaSx88u6BP7IAO6X5happ8CU75AfYkT9LeaP
    g+8Cr2Zb+T4nBR/VJypszKpJ0Xi9gMQdWYRGVnLOrdSarYPrsO1DMgf22Nk3b68v
    zMZmwnh/RFGuvV52dHZz3Nve0F4V9cLYTSl7twoPP75oFU/GFU49NIzhIOESEyvP
    Fg10QpEE1mAT7LTmEWv1
    =3GZY
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Java heap space not reserved

    Thanks for your quick reply.

    The same problem occurs when I login as root.

    When setting up the VM, I noticed that the memory space was set at something like 350 MB, which is a lot less than I'd like. I didn't know how to change it on VMWare, however.

    My hardware has 8 GB memory and lots of disk space. Is this the problem and does anyone know how to set the VMWare limits (hopefully without re-installing SUSE) ?

    Chris

  4. #4

    Default Re: Java heap space not reserved

    The problem was due to low memory in the virtual machine.

    For VMWare users, the memory can be adjusted by shutting down the SUSE machine and clicking the "Settings" switch. Click the resulting the "Processors & RAM" setting and set the memory. I set it to 2 GB.

    On restart, Java ran correctly.

  5. #5

    Default Re: Java heap space not reserved

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Excellent work. Thank-you for posting back your solution. Most VMs (as
    you found) allow reconfiguration of memory, though most of them (in my
    experience) also require either the VM to be down or restarted to apply
    those changes (fairly normal of any system changing RAM amounts, except
    insanely-high-end servers it seems, like the ones that MAY be running the
    VMs as the host).

    Good luck.





    christopherkimball wrote:
    > The problem was due to low memory in the virtual machine.
    >
    > For VMWare users, the memory can be adjusted by shutting down the SUSE
    > machine and clicking the "Settings" switch. Click the resulting the
    > "Processors & RAM" setting and set the memory. I set it to 2 GB.
    >
    > On restart, Java ran correctly.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKaNFWAAoJEF+XTK08PnB5JFcP/3Gd/+M/iIOigBXl9EK6fU82
    Nx6dKyKbEs73Akh61xxMXMTb/Fkw22VuChTLNyrV9N9mq472eMWHXaD2DHmN463I
    CUYGCIBWZRAEaaHf+ViYcNUu98ke5jg5ZXTGvYJTBPC9RXI8jIq1lN9mdDLgrD1q
    pHO4snAiwqeiqdrztv68q//TfdrEQliIt+Led92eEHybHeUy33pxZAWPTu8mZRuN
    se+7YYOQAWh6nSAcPlz25lmthkKhNE1etk18cg5HRQVYN40oSxFP0Lvaof4zCHad
    O7Uyt8UV2zUpMIROnFA9MoBy5xpvoTP2pnIbhNiXsDVbuA8S+lMhKgbTUwt6NI17
    sBLbXD/RvGT8mUchT1yqEDM1cfxXV+q0nr85b9XK1s41sRmz8/SXy5DwOFyOm1Iq
    CLis5WT/sIzI+S+qcrTN5ApyX7DzEoqrCAdNZwUH7zpor1RIn+i+M4sZDsRMfB15
    l1FP8DlMGcr8tr8OVerT8vRlpc5ESENpJlsO5kXgi54esVujxJbWdB8vmSh5fSdy
    mvsGigf8KYWp+XUU/LWM0Mri8hlXin73iXmzzZVkbydjrkPhf2ogYjk35j78PajI
    k0Cm07dgx7LfjanU1fv21ERPfuOhZMnRmBYo6gPeYaCU74aVY/ZOxcKsFH900geZ
    zWne7AmKFBMp8ovHVRch
    =pCwn
    -----END PGP SIGNATURE-----

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •