Results 1 to 6 of 6

Thread: Help with windows loading on KDE

  1. #1

    Question Help with windows loading on KDE

    HI, I'm using Opensuse 11.1 and KDE 4.2.2

    I can't remember exactly when it started happening, but here is my problem.

    Everytime I bring up a new program initially (i.e. Firefox), the window opens up on the top left corner (position 0,0 I'm guessing).
    The problem is that my taskbar is set on top and the window load behind the taskbar, so if I need to move the window towards the center I would need to hold Alt and click (this is because I have compiz loaded).

    Is there anyway to have the window load where it was last unloaded? Everything else is working great, just having this annoying issue.

    Any help is greatly appreciated.

    TIA

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Help with windows loading on KDE

    How about a screenshot? I'm struggling to figure out what you mean. The task bar is usually at the bottom.

    Check here if this is what you mean

    you need to choose the correct option for you
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Help with windows loading on KDE

    Hi,

    Try this out. Make sure to have firefox open and maximized.

    Open Configure Desktop (Personal Settings) then under the General tab in the Look and Feel category click into Window Behavior. Click the category Window-Specific then click New.

    Click Detect Window Properties then click anywhere inside firefox. It will detect the window properties and give you options of what to define it as.

    Tell it to Use Window Class (whole application) and click okay.

    Then under the Geometry tab put a check next to Position. Finally, choose Remember, from the drop down menu, or you can tell it to apply a certain position initially and specify the position. Click okay, then click apply.

    Position firefox under the Panel then close it. Open it up and see if that works.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Help with windows loading on KDE

    ricupg adjusted his/her AFDB on Thursday 23 Jul 2009 12:16 to write:

    >
    > HI, I'm using Opensuse 11.1 and KDE 4.2.2
    >
    > I can't remember exactly when it started happening, but here is my
    > problem.
    >
    > Everytime I bring up a new program initially (i.e. Firefox), the window
    > opens up on the top left corner (position 0,0 I'm guessing).
    > The problem is that my taskbar is set on top and the window load behind
    > the taskbar, so if I need to move the window towards the center I would
    > need to hold Alt and click (this is because I have compiz loaded).
    >
    > Is there anyway to have the window load where it was last unloaded?
    > Everything else is working great, just having this annoying issue.
    >
    > Any help is greatly appreciated.
    >
    > TIA
    >
    >


    If you unlock widgets and then click the cashew on the task bar you should
    be able to configure it to allow windows to cover, then you can drag the
    window down?

    Or does that not work in compiz?

    Also have a look in "Configure Desktop>advanced>Window behaviour you should
    be able to change the placement to smart and see if that helps also there
    you can set window specific settings that might do it.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  5. #5

    Default Re: Help with windows loading on KDE

    Thank you very much for the reply. After reading everyone's suggestions the last one from baskitcase gave me the idea.

    At first I went as suggested to Configure Desktop>advanced>Window behaviour, but it was already set to Smart.

    After that it may me think. I'm using compiz and it controls the window behaviour. So I went to compiz setting and enable the Place Window plugin and voila'! My windows are opening correctly.

    Thank you again.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Help with windows loading on KDE

    Thank you very much for the reply. After reading everyone's suggestions the last one from baskitcase gave me the idea.
    Shucks - and after all that thinking I had to do and you choose Mark's idea!

    Happy you sorted it
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •