Results 1 to 6 of 6

Thread: unlock session

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default unlock session

    hi

    i use kde 4.3 when i lock the session and come back later, i can't unlock the session... all is grey (windows login...)

    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: unlock session

    Disable all screensavers and screen powersaving
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default Re: unlock session

    i don't think screensaver and energy save are related to this problem...

    screensaver is already disabled... will try to disable energy saver

  4. #4
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default Re: unlock session

    i got the same problem

  5. #5

    Default Unlock session

    Same problem here, but I did find a temporary solution,

    simply rename /usr/lib64/kde4/libexec/kscreenlocker to something else.
    This will stop the system from locking up, but may be a security problem...
    ~!Keep Moving Forward!~

  6. #6

    Default Re: unlock session

    In openSuSE 11.2/KDE 4.3.1 (Also I've had this issue in SLES 11)

    It seems that there is no way to disable the screensaver.
    I've turned off powersaving and the screensaver.

    I've looked for a way of disabling the screensaver from
    krunner or kdeinit and can't seem to find a way.

    I've seen a post saying to just delete the kscreenlocker binary.

    I'd think there would be some way of just telling kde not to run
    /usr/lib/kde4/libexec/kscreenlocker --forcelock

    Any ideas on how to fix without an rm?

    Here's a ps of how it kscreenlocker is starting.
    (I'm assuming that --forcelock means to override whatever the user wants...)

    charles 2917 1 0 Jan05 ? 00:00:01 kdeinit4: krunner [kdeinit]
    charles 12634 2917 0 Jan05 ? 00:00:00 \_ /usr/lib/kde4/libexec/kscreenlocker --forcelock
    charles 12642 12634 0 Jan05 ? 00:00:00 \_ kblankscrn.kss -root

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •