Results 1 to 7 of 7

Thread: MPlayer with opensuse 11.1

  1. #1

    Default MPlayer with opensuse 11.1

    this is just a quick guide to installing MPlayer rpm from packman
    >>PackMan :: Package details for MPlayer
    >>MPlayer-1.0rc2_r29116-2.pm.2.i586.rpm
    i go to start+computer+install software
    rpm -ivh MPlayer i get
    warning: MPlayer-1.0rc2_r29116-2.pm.2.i586.rpm: Header V3 DSA signature: NOKEY, key ID 9a795806
    error: Failed dependencies:
    libamrnb.so.3 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libamrwb.so.3 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libdca.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libdirac_decoder.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libdirac_encoder.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libdvdnavmini.so.4 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libenca.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libfaac.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libfribidi.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libmp3lame.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libtwolame.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libx264.so.67 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libxvidcore.so.4 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586

    with yast i can only find
    libdirac encoder and decoder, libdvdnav4, fribidi-devel, SDL-devel(needed to install libmp4v2-devel to install libfaad-devel to install libfaac to install mplayer) and yasm-devel.
    with all dependencies that installed after i do a rpm -ivh MPlayer i get

    libamrnb.so.3 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libamrwb.so.3 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libdca.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libenca.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libfaac.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libmp3lame.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libtwolame.so.0 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libx264.so.67 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
    libxvidcore.so.4 is needed by MPlayer-1.0rc2_r29116-2.pm.2.i586

    with rpms from packman.links2linux.org and RPM Search i can find all i need to install MPlayer, i use command line [rpm -ivh package.rpm] to install, i dont wanna put in my pass a lot.
    libamrnb-devel(requires libamrnb3), libamrwb-devel(requires libamrwb3), libdca-devel(requires libdca0), libenca-devel(requires libenca), libfaac-devel(requires libfaac-devel,libfaad-devel,libmp4v2-devel), libmp3lame-devel(requires libmp3lame0), libtwolame-devel(requiring libtwolame), libx264-devel(requires libx264-67 and yasm-such a ******* to set up this go around i just did the 1 click install on packman)libxvidcore-devel(requiring libxvidcore4). and thats it.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: MPlayer with opensuse 11.1

    If you have the repositories OSS, Non-OSS, Update and Packman setup in your software package manager, as described here: Repositories/11.1 - openSUSE-Community Just those 4. You should find OSS, Non-OSS, and Update already setup, and typically one just needs to add Packman. In any case, ensure you have those 4 and JUST those 4 selected. I recommend you disable ANY and ALL other repositories. I repeat, disable ANY and ALL other repositories. In particular disable videolan. If you do NOT do this, you could experience the sort of problem you reported.

    Then go to YaST > Software > Software management, and change the "filter" to "search" and select the Packman packaged MPlayer for installation. Note you can tell Packman packaged versions by the "pm" in the version number.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: MPlayer with opensuse 11.1

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: MPlayer with opensuse 11.1

    actually I'm on a PPC (iMac G5) and have those repos enabled and get all kinds of dependency errors. have to go around web and pick up libs from who knows where

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: MPlayer with opensuse 11.1

    Quote Originally Posted by libraryeye View Post
    actually I'm on a PPC (iMac G5) and have those repos enabled and get all kinds of dependency errors. have to go around web and pick up libs from who knows where
    If those are the only 4 repos you have enabled, and if you did a clean install on your openSUSE (and not an update) and if you did not go thru a phase with many other enabled, then you have picked up a problem that should be reported to the Packman MPlayer packager.

    You can contact the packagers clicking on their name in the Packman page here which can give you their email address:
    MPlayer-1.0rc2_r29116-2.pm.2.ppc.rpm MPlayer (Henne Vogelsang)

    BUT if you previously messed around with many repositories, and downloaded apps from other repositories, and/or if you did not do a clean install, but rather did an update install, then it is best to address that first, as opposed to wasting the packager's time.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: MPlayer with opensuse 11.1

    Quote Originally Posted by libraryeye View Post
    actually I'm on a PPC (iMac G5) and have those repos enabled and get all kinds of dependency errors. have to go around web and pick up libs from who knows where
    You can save the error from Yast using the expert button. Then post it here and we can walk you through it.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: MPlayer with opensuse 11.1

    Quote Originally Posted by caf4926 View Post
    You can save the error from Yast using the expert button. Then post it here and we can walk you through it.
    In addition to caf4926' suggestion, please also provide output of:
    zypper lr -d

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •