Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: OS 11.0 freezes during startx using kde4

  1. #1

    Default OS 11.0 freezes during startx using kde4

    just re-installed opensuse 11.0. it boots fine into shell, but entering startx to start x11 (kde 4) freezes as the progress bar
    reaches halfway mark.

    runs fine without kde, tho i haven't thoroughly tested.

    log files don't exactly match:

    root> tail /var/log/Xorg.0.log
    (**) Mouse[1]: Sensitivity: 1
    (II) evaluating device (Mouse[1])
    (II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
    (II) evaluating device (Keyboard[0])
    (II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
    (II) Mouse[1]: ps2EnableDataReporting: succeeded
    Could not init font path element /usr/share/fonts/TTF/, removing from list!
    Could not init font path element /usr/share/fonts/OTF, removing from list!
    (WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
    (WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)


    and

    root> tail /var/log/Xorg.0.log.old
    (**) Mouse[1]: ZAxisMapping: buttons 4 and 5
    (**) Mouse[1]: Buttons: 9
    (**) Mouse[1]: Sensitivity: 1
    (II) evaluating device (Mouse[1])
    (II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
    (II) evaluating device (Keyboard[0])
    (II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
    (II) Mouse[1]: ps2EnableDataReporting: succeeded
    Could not init font path element /usr/share/fonts/TTF/, removing from list!
    Could not init font path element /usr/share/fonts/OTF, removing from list!

    ================================================

    all else is still running - i run a watchdog script before startx that will eventually reset (sleep 500; reboot

    running on amd abit va20 (if it matters :-)

    menu.lst line is
    kernel /vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-label/suse11_root resume=/dev/sda9 splash=silent showopts vga=0x317

    thoughts would be appreciated
    tnx

  2. #2

    Default Re: OS 11.0 freezes during startx using kde4

    update with add'l info:

    sax2 runs ok

    # tail -24 /var/log/messages
    Jul 20 09:03:23 linux-vezw kernel: [drm] Initialized drm 1.1.0 20060810
    Jul 20 09:03:23 linux-vezw kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    Jul 20 09:03:23 linux-vezw kernel: [drm] Initialized via 2.11.1 20070202 on minor 0
    Jul 20 09:03:23 linux-vezw kernel: agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
    Jul 20 09:03:23 linux-vezw kernel: agpgart: Device is in legacy mode, falling back to 2.x
    Jul 20 09:03:23 linux-vezw kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
    Jul 20 09:03:23 linux-vezw kernel: agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
    Jul 20 09:05:49 linux-vezw kernel: agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
    Jul 20 09:05:49 linux-vezw kernel: agpgart: Device is in legacy mode, falling back to 2.x
    Jul 20 09:05:49 linux-vezw kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
    Jul 20 09:05:49 linux-vezw kernel: agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
    Jul 20 09:10:38 linux-vezw shutdown[3795]: shutting down for system reboot

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: OS 11.0 freezes during startx using kde4

    What happens if you boot in Failsafe?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: OS 11.0 freezes during startx using kde4

    same thing.

    however, if i boot, then login as root, then startx, it comes up. maybe a permissions problem?

    but then, even after i run kde as root, if i change something like window appearance or behavior, as soon as i click 'apply', it freezes. (this is actually the behavior that caused me to re-install)

    still, the watchdog in the bkground runs and closes down gracefully.

    does ctl-alt-bs shutdown the OS 11.0 X server? doesn't for me, altho i'm using a kbd that maps DEL -> BS, so maybe i can't get around that mapping.

    tnx for replying.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: OS 11.0 freezes during startx using kde4

    Not a permissions issue. But user issue.
    You should not login to the desktop as root!

    You could try this: Boot to the level 3 CLI and login as user, then switch to su and this:
    Code:
    sax2 -r -m 0=vesa
    But this may not work, so now........

    Boot to level 3
    run yast
    and create a new user
    reboot and login with this user and if you get in, don't change anything.

    I think your issue is related the graphics hardware and settings you are changing in the desktop
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: OS 11.0 freezes during startx using kde4

    i think there may be some confusion - booting up to init lvl 3 is what i have been doing all along. then i log in as the user i created during installation, su to root, background the watchdog script, log out of root, run startx as regular user 1. kde freezes mid-load.

    running X as root was done only as an experiment.

    per your request, i created a user user2. su to root, background the watchdog, log out as root, startx. for some reason, user2 can run X11. the behavior of X/kde is the same for user2 and root.

    i'm confused - how is a user created during installation diff from a user created under yast? both belong to the same groups: dialup, video, users.

    but even tho user2 can get X11/kde up, clicking 'apply' freezes the screen (the mouse and kbd, at least) - i'm not doing anything fancy with the video when i click 'apply'. it can be anything from change the presentation scheme to remap the kbd to change the meaning of 'ctl-left-arrow'.

    any enlightenment?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: OS 11.0 freezes during startx using kde4

    but even tho user2 can get X11/kde up, clicking 'apply' freezes the screen
    Clicking 'Apply' to what?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: OS 11.0 freezes during startx using kde4

    oh, sorry -
    in 'control center', if i change something like window appearance or behavior, or change a kbd mapping or mouse button actions, as soon as i click 'apply', it freezes (no response to mouse or kbd).

    suse 10 (et al) works just fine.

    as i mentioned earlier, i fire off a script (as root) that is nothing more than "sleep 500; reboot" to prevent having to power cycle the box after a freeze.

    so the cycle goes like this: boot, log in as user2, su, background the script (watchdog&), exit back to user1, startx, bring up (for example) window behavior config, change (for example) focus follows mouse, click apply, freeze.

    logging in as user1, same behavior except it locks up as the progress bar gets to the halfway point as kde is loading.

    so, any idea why user1 can't even get X/kde running but user2 can? and why user2's desktop gets locked up applying changes?

    tnx

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: OS 11.0 freezes during startx using kde4

    Have you considered installing kde3 from software management patterns and then login with that, see if it behaves better?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: OS 11.0 freezes during startx using kde4

    i will attempt to do that today.
    couple ?s:
    should i install from the dvd or from latest?
    how do i make it the active gui after i get it installed?

    if that seems ok, i guess i could then update kde4 and try that again.

    tnx

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •