In case this can help someone else:

I'm running openSUSE 11.0 on a Presario V2000 laptop. (I haven't wanted to go through the chore of installing 11.1 and am waiting for 11.2 to come out in November.) Here are 2 annoyances and their solutions.

I recently added the Mozilla repo and upgraded to Firefox 3.5.1, only to get this error message when visiting BoingBoing.net:

Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

(repeated about 5 times in the terminal), with a segfault message, and a Firefox crash. (This is similar to bug #242073, from 2007, with a fix of "Complain to Adobe".) Reverting to Firefox 3.0.11 didn't fix the problem, but uninstalling the "libflashsupport" package did.

Problem #2 was that running the Yast2 package manager popped up a little error box complaining about a qt error and then it would quit (see this forum thread for a more complete description of the problem).

The solution was to upgrade "yast2-qt-pkg" using zypper from a terminal; they have a patched version that fixes the problem.