Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Canon Poweshot SX10 IS and digiKAM

  1. #1
    Join Date
    Jul 2009
    Location
    Bratislava,Slovakia,EU
    Posts
    6

    Default Canon Poweshot SX10 IS and digiKAM

    Hi i just got Canon Powershot sx10 IS. but i can not find my canon in a list but what i know it is a supported model...
    any idea how i can download my pictures from the camera?

  2. #2
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Canon Poweshot SX10 IS and digiKAM

    I have a Canon SX110 IS, and it works fine with OpenSuse 11.1 x64 & KDE 4.2.

    All I did was plug in the USB cable and the system found it. Started digikam and selected an option for the Canon (though I can't remember which one it was! ) It was down toward the lower end of the Canon area of the menu, something like "other Canon" or something similar.

    Can't be more specific at the moment as I'm using my sister's XP box, home being rather far away at the moment . . .

    Hope this helps.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Canon Poweshot SX10 IS and digiKAM

    If your camera is not on the list, generic PTP camera has a good chance of working with recent cameras.

  4. #4
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Canon Poweshot SX10 IS and digiKAM

    Quote Originally Posted by ken_yap View Post
    If your camera is not on the list, generic PTP camera has a good chance of working with recent cameras.
    Ah, thank you.

    That's what I couldn't remember earlier. The Canon PTP option will work just fine. My Poweshot SX110 isn't on the list either, but the PTP mode works okay.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  5. #5
    Join Date
    Jul 2009
    Location
    Bratislava,Slovakia,EU
    Posts
    6

    Default Re: Canon Poweshot SX10 IS and digiKAM

    it doesn't work for me,
    it returns error: Failed to list in /Store_00010001/DCIM/101CANON
    any idea?

  6. #6
    Join Date
    Jul 2009
    Location
    Bratislava,Slovakia,EU
    Posts
    6

    Default Re: Canon Poweshot SX10 IS and digiKAM

    no idea?

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Canon Poweshot SX10 IS and digiKAM

    I don't know this model. Do you need to do anything on the camera side to enable PTP mode? What do you get in /var/log/messages when you plug in the camera? It should show the USB device being detected.

  8. #8
    Join Date
    Jul 2009
    Location
    Bratislava,Slovakia,EU
    Posts
    6

    Default Re: Canon Poweshot SX10 IS and digiKAM

    okey so i looked to messages and there is

    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: new high speed USB device using ehci_hcd and address 5
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: configuration #1 chosen from 1 choice
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: New USB device found, idVendor=04a9, idProduct=318d
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: Product: Canon Digital Camera
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: Manufacturer: Canon Inc.
    Jul 24 14:39:08 linux-jwlb kernel: usb 1-1: SerialNumber: 7ECEA342341D48308301F09DCBB5EC67

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Canon Poweshot SX10 IS and digiKAM

    This exchange in the digikam devel forum was after 11.1 was released so it is possible you need a bleeding edge version of libgphoto or digikam or something. You'll have to judge for yourself.

    [Digikam-devel] [Bug 184954] New: unable to delete items from camera - canon sx10is

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Canon Poweshot SX10 IS and digiKAM

    If there is a bug on this, then my post may not help. ...

    ... but I'm curious, with your camera not plugged in, type in konsole or terminal:
    su -c 'fdisk -l'
    df -Th
    and enter root password when prompted for a password (note the "-l" in fdisk is a lower case "L" (for list)), then plug in your camera, and repeat that.
    su -c 'fdisk -l'
    df -Th
    Are there any differences?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •