Results 1 to 7 of 7

Thread: removing desktop effects

  1. #1
    maayanm NNTP User

    Default removing desktop effects

    hi,
    i have a SUSE 11.1 installed on my laptop, using VMware.
    i accidentally turn on the desktop effects on the root user. then the screen went blank...
    every time i log in as root a get a white sceern.
    i have an access to the admin user.
    is there anything i can do to disable the desktop effects at the root user?

    thanks.

  2. #2
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: removing desktop effects

    Hi,
    assuming that you are using KDE 4,
    pls login as another user/root in CLI,
    disable the effect by editing the kwinrc file
    located at ~/.kde4/share/config/

    Code:
    Enabled=false
    Btw, logging in as root is not a good practice,
    you should log in as a normal user and use su or sudo instead.

    HTH
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  3. #3
    maayanm NNTP User

    Default Re: removing desktop effects

    Hi,
    first of all, thanks.
    but I can't find this directory (/.kde4), so I'm guessing I'm not using KDE...
    Is there any other directory that I can try to find this file?

    And I know it's note a good practice to run as root, but must of the time I have to do so, in order to run the services that I need.

    thanks again.

  4. #4
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: removing desktop effects

    Hi,
    in order to run something as root you can do this from a normal user terminal:

    Code:
    su
    then type in your root password,
    and any command you run in the terminal will be run as root.

    you just need to type exit to end the root session.

    or you can use sudo from a terminal.

    You can find out what Desktop Environment that you are using by clicking on the session type at the Login screen.

    If you are using KDE4,
    you should find the config file at:

    Code:
    /root/.kde4/share/config/kwinrc
    to disable the desktop effect, please edit the
    enabled=true to enabled=false
    under the [compositing] section

    Good luck
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  5. #5
    maayanm NNTP User

    Default Re: removing desktop effects

    Hi,
    I'm using gnome.
    what is the path for the config file?

    thanks

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,372
    Blog Entries
    1

    Default Re: removing desktop effects

    Hi maayanm

    Not a Gnome user, but try this: Navigate to Computer->More Applications->Desktop Effects, then uncheck 'Enable Desktop Effects'

    Hopefully that will work for you.

  7. #7
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: removing desktop effects

    Hi,
    please edit /etc/X11/Xorg.conf

    look for
    Code:
    Section "Extensions"
      Option "Composite" "on"
    EndSection
    change it to "off"

    restart your X server,
    and do as what the previous post said

    Good luck
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •