Results 1 to 6 of 6

Thread: Filemanager Dolphin - Super User Mode

  1. #1

    Question Filemanager Dolphin - Super User Mode

    Question:
    0. Logged into my machine as /root user
    1. Starting Dolphin The filemanager - in super user mode.
    2. I enter sysinfo:/ in Dolphins location bar
    >>>> I see the "my Computer Overview"

    3. Looking under Disk Information i see my usb stick
    4. When hovering my mouse over the usb stick a little tooltip appears with the following text:
    "Press the right mouse button for more options like Mount of Eject"

    5. I press my right_mouse_button .... these are the following menuchoices i get:
    - Open in new window
    - Open in new tab
    - Open with >
    - Preview in filesize view
    - Actions >

    Question:
    What have i forgotten, done wrong? I have searched all submenus options but there is no MOUNT or EJECT Command to be found???



    Regards, Ronald

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,614

    Default Re: Filemanager Dolphin - Super User Mode

    One thing first Ronald. Do I realy understand that you are loged into ths GUI as root? This should never been done!
    SDB:Login as root - openSUSE
    When you want to use Dolphin in super user mod, doe this from the GUI of a normal user. There must be an entry for that in the Kmenu.

    As I use openSUSE 10.3 and KDE3.5 and thus use Konqueror as a filemanager I am not sure I can help you. But I would not expect a mount option, because it is most probably allready mounted. And in my system it says "Eject" for a CD/DVD, but "Remove savely" for USB sticks (spitting out the stick isn't supported by the hardware I suppose ). Can you find that option?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Filemanager Dolphin - Super User Mode

    Ditto
    DO NOT login as root

    You need to go to View - Panels (and add- Places)

    With that the usb device will show there and you right click eject
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Filemanager Dolphin - Super User Mode

    @Henk
    Thanks for the article about logging in as root.
    I do not yet have enough "commandline linux knowlegde" to solve this problem @ the prompt. That is why i used the GUI program.

    *I normally do not use this (logging in as root) but this time i was using root-access to see if this could solve the USB stick problem. So to determine is the access-level was the cause of my usb stick challenge or something else.

    I always work under my own USER_LEVEL account on Suse.

    -------------------------
    @caf4926
    Thanks for the advice. see * for my reason why.
    -------------------------

    @To all:
    I've added the line [/dev/sdc1 /media/usb auto auto,user] to my /etc/fstab file and now SUSE will mount the usb stick automatically during startup of my machine. So far it works good.

    Question:
    In the old days, when working on windows XP, this stuff happens automatically when i plug in a usb device..
    I automatically get a drive letter pointing to the usb stick.

    1. Is this also possible on Suse 11?
    2. If yes, how can it be done, so that i am able to mount the usb stick as a USER and not as a ROOT?

    Thanks for your helpfull tips, hints
    Ronald

  5. #5

    Default Re: Filemanager Dolphin - Super User Mode

    It doesn't get mounted for the following reasons, if there ever be any malware for linux it won't start unless you mount it. When You click the corresponding devic on the left in dolphin ti will mount won't it? So where is the problem??
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,888
    Blog Entries
    1

    Default Re: Filemanager Dolphin - Super User Mode

    Question:
    In the old days, when working on windows XP, this stuff happens automatically when i plug in a usb device..
    I automatically get a drive letter pointing to the usb stick.
    With KDE3 this was also able to be the case, if preferred. With KDE4, the Dolphin file manager has device notification for external media, but they are not mounted until selected. This is a deliberate design. (Maybe in the future, more control may be given with respect to external media mounting options).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •