Results 1 to 8 of 8

Thread: Took latest security update and system will not load.

  1. #1
    codecx NNTP User

    Default Took latest security update and system will not load.

    After taking the latest security update for X11 server and Mesa driver the OS will not start/load the x11 server. I've been running fine the 64 bit system with original ATI 9800 HD series driver. The openSUSE11.1 loads fine until it is about to start x11 and KDE4.1. Then it hangs, nothing happens.

    Is there any way to fix this problem without reinstalling entire OS? I would hate to do this, since I have a lot of stuff saved there.

    Many thanks...

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Took latest security update and system will not load.

    Try booting in Failsafe
    Then re-install your ati driver as you did previously
    If you installed the driver manually you will need to follow that method again

    logout and back in, or reboot.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Took latest security update and system will not load.

    Further to what caf4926 noted, there was an update to X11 in the past couple of days, and it broke the proprietary graphics on a number of user's PCs.

    I know it broke my proprietary nVidia driver build. I have not checked the other PCs in our house yet. I was able to rebuild my nvidia driver an my X window (with KDE) was back in business again.

    Until you can rebuild the proprietary driver, you may be able to use the VESA driver (as an interim) with:
    sax2 -r -m 0=vesa

    You can then use this opportunity to download the latest ATI driver and rebuild it per instructions here: ATI - openSUSE

    But if the "vesa" driver does not work, you can download the latest ATI driver from another PC, or download it with wget from run level 3, and once copied on to your PC, rebuild it per the instructions here: ATI - openSUSE

  4. #4
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Took latest security update and system will not load.

    Same problem for me the last month. I solved this rolling back to the old xorg and downgrading the mesa libs. I hope that your internet connection is up even in text mode. I mean that the internet is not controlled by networkmanager otherwise it's a kick in the ass. If you have cnetworkmanager installed you can controll the connection with this. When you are connected run yast then select packagemanager and search xorg. Now select the old version. Look also for mesa and do the same. Wait... Reboot just to be sure. At this step i still had on x. So i re-configured the x environment with sax2 and it worked again. If this should not work for you there is the chance to have c vesa display so at least you can do some backup. This way you run sax2 -r m0=vesa. Accept the new settings and be patient: bad resolution and no accel. Hope this helps
    -- sorry oldcpu posted while i was writing. You see that most of my advice is the same--
    Last edited by bcrisciotti; 17-Jul-2009 at 02:41. Reason: Acknowledgements

  5. #5
    codecx NNTP User

    Default Re: Took latest security update and system will not load.

    I defaulted video driver setting to vesa with sax2 in safemode, then reinstalled ATI driver and everything is running great again.

    Thank you all for suggestions.

  6. #6
    codecx NNTP User

    Default Re: Took latest security update and system will not load.

    Hello,

    I'd like to ask for some help again. I tried to uninstall ATI driver from the OS in order to take latest kernel update and other ones too. I followed the procedure ATI recommends. The driver did not uninstall. So, I decided to use sax2 -r -m 0=vesa "procedure". Now the X11 will not start at all, either in normal or failsafe mode. There is just a black screen. Is there any way to go back to working condition? thx.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Took latest security update and system will not load.

    Quote Originally Posted by codecx View Post
    Hello,

    I'd like to ask for some help again. I tried to uninstall ATI driver from the OS in order to take latest kernel update and other ones too. I followed the procedure ATI recommends. The driver did not uninstall. So, I decided to use sax2 -r -m 0=vesa "procedure". Now the X11 will not start at all, either in normal or failsafe mode. There is just a black screen. Is there any way to go back to working condition? thx.
    You may need someone on openSUSE who has some ATI experience, while don't have much. Still, I know if one installs "the hardway" via the ATI installation script, it creates an rpm file that needs to be removed when the next installation script is run. What is the output of
    rpm -qa | grep fglrx
    if you see an rpm, then you may wish to remove that rpm with:
    rpm -e $(rpm -qa '*fglrx*')
    and then with that removed, its possible that the sax2 command will then work:
    sax2 -r -m 0=vesa

    The reference for that is here:
    ATI/The Hard Way - openSUSE

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Took latest security update and system will not load.

    Are you making the vesa switch from level 3?

    Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=...etc
    Remove all text and now type just the number:
    3
    and hit enter

    at the login type your user name and then password
    now type:
    su
    then the root password

    now type this:
    sax2 -r -m 0=vesa
    (N.B. the 0 is a zero not a letter)

    now reboot: type: reboot
    if you don't get a gui login
    login as user at cli and try this at the cli
    startx
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •