Results 1 to 6 of 6

Thread: Unable to download primary.xml.gz

  1. #1

    Default Unable to download primary.xml.gz

    The opensuse 11.1 updater does not work at all. The download of

    constantly fails for 3 weeks now. After ~20% an error message is being prompted, no matter if I update via Updater Applet or via KDE. Even the direct download of the file from the explorer via Save fails without an error message.

    I am working on a distribution from march-april this year from without any modifications. I am not interested in being asked about the kernel I am using, why I don't use zypper instead of KDE etc. etc.

    I know that I am not the first user running into this problem as a simple search on the internet easily shows.

    The point of the matter is, that I firstly installed the system middle of juin. At that moment I was still perfectly able to update from the predefined repositories.

    Then I directly got the usual problems with the non-loaded KDE-Media-Manager and a non-recognized intel-sound-board. Audio-CDs wouldn't be recognized in the usual directory viewers and Amarok wouldn't play the music.

    Silly enough that nonetheless Cafeine plays the CD without problems provided I switch on the speakers which have been (I don't know why) switched of by the start-up procedure, possibly because the "audio board doesn't work". Why doesn't it work if even Cafeine brings it to play music. MS Windows never complained!

    What so ever: At this moment the updater still worked perfectly on my analogue Modem. Then I tried to get rid of the just indicated problems by trying a fresh installation. The installation was done without positive effect at the end of June but from that moment I never again could complete an update due to the indicated download problem.

    I also tried to let KDE go and to start up with GNOME: However GNOME wouldn't allow me to activate german keyboard with "DEAD KEYs". Any mysterious error message popped up and the keys were unavailable. Now write a letter without those keys... !

    The indicated update problem is not the first one: I had an early version of open suse 11.1 on my computer but since february the updater was blocked by an ATI-update requiring another kernel than used by the rest. This flaw mislead me to try the later version...

    My personal wish and feeling would be:

    1) Please have a look at the download logs on your servers in order to find out when and why exactly the download of this file constantly fails on so many different computers.

    2) Please ensure that distributions are tested before throwing them on the market. I don't postulate you to test all the proprietary applications which may be in the field. But at least the most elementary things like amarok, media manager, keyboard etc. should work.

    Frankly, I was completely unaware what sort of mess could really be produced by an OS until I ran into Linux. Several time I was at the point of throwing everything to the rubbish dump in order to stop losing time on out-of-the-world problems. The worst thing is: Whenever you ask for a solution they drive you into another problem with the best will and wishes. For that reason again: Don't bother me with advices on zipper, alternative repositories etc. Just have a look at your own side of the problem.

  2. #2

    Default Re: Unable to download primary.xml.gz

    Well being your first post may I suggest a better tone...

    But you do realise even with the rant you gave you didn't include any useful information like the error message. Then next you do realise that suse isn't in control of the mirror you use(Let alone any of us being able to help without the info), and finally that telling them to look at there server here is about much use as standing in the middle of the Atlantic and shouting it.(Though mirror makes it pointless if it was even the correct place)

    I'm inclined to think you dont want help so may I suggest you ask a mod to move it to soapbox.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  3. #3

    Default Re: Unable to download primary.xml.gz

    Thank you, son. Exactly the sort of answer I expected.

    As I told you: In the end it's never the OS which fails but the user. Strangely: The next CD brings different problems on the same unchanged PC. That's certain.

    That's why I asked you for the two things at the end of my posting. Not more: Test your software, check the indicated servers if possible. May be someone set a time out which blocks access for slow modems after some seconds...

  4. #4

    Default Re: Unable to download primary.xml.gz

    Here is the therotical answer for you.

    We've checked our servers here they are all fine but as we use MirrorBrain | Welcome! it is highly likely to be a problem with the server you're using. So if you report to the mirror you use perhaps they can assist further. Other wise it may be a problem with the network between the mirror and your own network, which we can't assist with.

    Mmm now you read stuff I don't post impressive let me see where did I say the user... Ahh I know useful information and not wanting help, yes I agree now I see it. Still we lack the info and you don't wish to provide it, well guess what I'm not interested in assisting further and I doubt anyone else is either.

    You do realise that the support received here is volunteer and free don't you?

    You've walked through the door after being invited for a free dinner and the first thing you said is that it smells like the dogs dinner. Well good luck go take your frustrations out on someone paid to receive them.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  5. #5

    Default Re: Unable to download primary.xml.gz

    I indicated the URL of the problem-causing file at the beginning of my initial mail. I am quite unable to give further details on the server, the IP etc. The repositories where automatically configured. The Update-progress was launched via Yast and Update Applet and failed. Also direct download failed without error or warning message. The byte-count of failure is variable. So the file itself is possibly not currupted. This phenomenon was repeatedly mentioned in this forum. Why should I care about my own Kernel version etc?

    It seems more likely that there is just a time-out. Files of similar or higher size can be downloaded from other sources without problems. It is just this file which causes trouble - repeatedly. I tryed to use other repositories but I don't know which of them are trustworthy and if I am allowed to mix different repositories. The ATI-repository used to be incompatible with the suse-repositories for several mounth and no update was possible.

    Then: I am unaware of the internal organization of and Novel at all. Also the responsibility in the Forum doesn't really interest me. My emal was not directed to a specific person whence I see no reason for any individual here to feel offended.

    Expressing a general emotion of anger may nontheless be allowed respecting the fact that from approx. 5 open suse distributions I buy at the station for ~ 10 Euro each usually 4 cannot be used at all for one or another reason. If the internet connection succeeds the sound board fails. But also the keyboard may produce trouble if the Media Manager is accidentally correctly loaded. The updates are a constant source of trouble which gets really expensive on a slow modem. Of course I might use high speed if it was available. etc. etc...

    Summary: Don't take everything personel... neither do I.

  6. #6

    Default Re: Unable to download primary.xml.gz

    Firstly my apologies it seems I was wrong and this is one of a few files that are directly downloaded. Most others are then redirected.

    Lets get some verbosity and try to find the problem. We'll have to drop to the command line.
    sudo zypper -vvv ref > catch.txt
    So now you should have a file called catch.txt at /home/user/catch.txt either cat this file in the terminal or open with an editor and post the content in code tags.

    At 10 euro that is not the officially supported box set
    openSUSE 11.0: Price List Euro that looks like 60 euros. And given you some limited paid support NOVELL: openSUSE: Support Requirements
    end off Topic
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts