Results 1 to 7 of 7

Thread: Amarok 2 fails to play music files (almost all ... )

  1. #1

    Default Amarok 2 fails to play music files (almost all ... )

    I installed Amarok 2 yesterday, but have this strange problem that it doesn't want to play music files. It's apparently not simply a problem with the sound output, the time indicator doesn't move at all.

    This is true for pretty much all files I've tried (mp3, ogg, wav) except (and weirdly enough) one , which plays fine (it's a short .ogg sound clip).

    MY SYSTEM ENVIRONMENT:
    OS: Linux 2.6.27.23-0.1-pae i686
    System: openSUSE 11.1 (i586)
    KDE: 4.2.4 (KDE 4.2.4) "release 2"

    MY REPOSITORIES:
    Code:
    #  | Alias                     | Name                      | Enabled | Refresh | Priority | Type   | URI                                                                                | Service 
    ---+---------------------------+---------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+-------- 
    1  | Extra:_hujq_(nchu.edu.tw) | Extra: hujq (nchu.edu.tw) | Yes     | Yes     |   99     | rpm-md | http://ftp.nchu.edu.tw/Linux/OpenSuSE/repositories/home:/hujq/openSUSE_11.1/       |         
    2  | Extra:_hujq_input_methods | Extra: hujq input methods | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/hujq:/input_methods/openSUSE_11.1/ |         
    3  | Extra:_kzarog             | Extra: kzarog             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/kzarog/openSUSE_11.1/              |
    4  | KDE:42                    | KDE:42                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/                   |
    5  | M17N                      | M17N                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/M17N/openSUSE_11.1/                      |
    6  | OOo-Stable                | OOo-Stable                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/    |
    7  | Packmann                  | Packman                   | Yes     | Yes     |   99     | rpm-md | http://packman.jacobs-university.de/suse/11.1/                                     |
    8  | repo-non-oss              | openSUSE-11.1-Non-Oss     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                       |
    9  | repo-oss                  | openSUSE-11.1-Oss         | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                           |
    10 | repo-update               | openSUSE-11.1-Update      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/
    I can also provide outputs from running different sound files with 'amarok --debug' from the shell, but they are quite long.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: Amarok 2 fails to play music files (almost all ... )

    install xine-phonon-backend and set Xine as backend in KDE4 control center -> Multimedia -> Backend

  3. #3

    Default Re: Amarok 2 fails to play music files (almost all ... )

    Great, thanks! Now my .ogg and .wav files at least play fine.

    Do you happen to know what I need to install for .mp3 files? I remember for Amarok 1, there was a package Amarok-xine (from Packman repo) that needed to be installed, but there doesn't seem to be anything codec-related for Amarok 2.

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: Amarok 2 fails to play music files (almost all ... )

    install the libxine libs from packman

  5. #5

    Default Re: Amarok 2 fails to play music files (almost all ... )

    Do you happen to know which libs I need in addition to the ones I already got?

    Code:
    S | Name               | Type    | Version         | Arch   | Repository          
    --+--------------------+---------+-----------------+--------+---------------------
      | libxine-devel      | package | 1.1.16.3-0.pm.3 | i686   | Packman             
      | libxine-devel      | package | 1.1.16.3-0.pm.3 | i586   | Packman             
      | libxine-devel      | package | 1.1.15-23.3.3   | i586   | openSUSE-11.1-Update
      | libxine-devel      | package | 1.1.15-20.8     | i586   | openSUSE-11.1-Oss   
    i | libxine-devel      | patch   | 582             | noarch | openSUSE-11.1-Update
    v | libxine1           | package | 1.1.16.3-0.pm.3 | i686   | Packman             
    v | libxine1           | package | 1.1.16.3-0.pm.3 | i586   | Packman             
    i | libxine1           | package | 1.1.15-23.4.1   | i586   | openSUSE-11.1-Update
    v | libxine1           | package | 1.1.15-23.3.3   | i586   | openSUSE-11.1-Update
    v | libxine1           | package | 1.1.15-20.8     | i586   | openSUSE-11.1-Oss   
    i | libxine1           | patch   | 856             | noarch | openSUSE-11.1-Update
      | libxine1-aa        | package | 1.1.16.3-0.pm.3 | i686   | Packman             
      | libxine1-aa        | package | 1.1.16.3-0.pm.3 | i586   | Packman             
      | libxine1-arts      | package | 1.1.16.3-0.pm.3 | i686   | Packman             
      | libxine1-arts      | package | 1.1.16.3-0.pm.3 | i586   | Packman             
      | libxine1-codecs    | package | 1.1.16.3-0.pm.3 | i686   | Packman             
      | libxine1-codecs    | package | 1.1.16.3-0.pm.3 | i586   | Packman             
      | libxine1-directfb  | package | 1.1.16.3-0.pm.3 | i686   | Packman
      | libxine1-directfb  | package | 1.1.16.3-0.pm.3 | i586   | Packman
      | libxine1-esd       | package | 1.1.16.3-0.pm.3 | i686   | Packman
      | libxine1-esd       | package | 1.1.16.3-0.pm.3 | i586   | Packman
    v | libxine1-gnome-vfs | package | 1.1.16.3-0.pm.3 | i686   | Packman
    v | libxine1-gnome-vfs | package | 1.1.16.3-0.pm.3 | i586   | Packman
    i | libxine1-gnome-vfs | package | 1.1.15-23.3.3   | i586   | openSUSE-11.1-Update
    v | libxine1-gnome-vfs | package | 1.1.15-20.8     | i586   | openSUSE-11.1-Oss
      | libxine1-jack      | package | 1.1.16.3-0.pm.3 | i686   | Packman
      | libxine1-jack      | package | 1.1.16.3-0.pm.3 | i586   | Packman
    v | libxine1-pulse     | package | 1.1.16.3-0.pm.3 | i686   | Packman
    v | libxine1-pulse     | package | 1.1.16.3-0.pm.3 | i586   | Packman
    i | libxine1-pulse     | package | 1.1.15-23.3.3   | i586   | openSUSE-11.1-Update
    v | libxine1-pulse     | package | 1.1.15-20.8     | i586   | openSUSE-11.1-Oss
      | libxine1-sdl       | package | 1.1.16.3-0.pm.3 | i686   | Packman
      | libxine1-sdl       | package | 1.1.16.3-0.pm.3 | i586   | Packman

  6. #6
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: Amarok 2 fails to play music files (almost all ... )

    libxine1 and libxine1-codecs from packman

  7. #7

    Default Re: Amarok 2 fails to play music files (almost all ... )

    Sorry, my mistake. I thought I had gotten all Amarok/Xine-related packages from Packman, but apparently not libxine.

    Thanks for your help, everything works great now!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •