Results 1 to 3 of 3

Thread: Xvid/Mpeg-4 on Opensuse? Any suggestions?

  1. #1
    Khallingstad NNTP User

    Default Xvid/Mpeg-4 on Opensuse? Any suggestions?

    Hi, I have just gone from Windows to Opensuse. I am familiar with Linux in general and have been using Linux Mint and Ubuntu. This time though I thought I would use Linux a bit more seriously and have chosen to use OpenSuse because I find it interesting.
    The problem I am having is that when I try to play an xvid file (in Totem Player) I get an error message: "Search for sutiable codec?" Then I can press "cancel" or "ok". Then a new error message pops up saying:"An Error eccoured. The Playback of this movie requires a XVID MPEG-4 decoder plugin which is not installed." Then it sends me to a webpage:" Software.openSUSE.org ". This webpage is of little use because these links don't give me much information. So what I am asking is, is there any players or plugin that I can download so that I can watch Xvid movies? In that case, can someone here tell me how to obtain this software? or plugin?

    Thanks in advance for replies.

  2. #2
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Xvid/Mpeg-4 on Opensuse? Any suggestions?

    Forget about codecs. Use VLC media player - it's in the repos.

    Checkout: WEBPIN - Videolan. Click the first button in the right hand corner.
    It plays EVERYTHING, alfready brings ALL codecs with it and even plays broken files. As for me, it's the BEST one around.

    Yeah, and don't forget to have FUN with it. Because it really rocks.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  3. #3

    Default Re: Xvid/Mpeg-4 on Opensuse? Any suggestions?

    Please follow the links presented on that webpage(follow the pink rabbit ): click on "Community Information" link,

    1. Multimedia - openSUSE-Community
    then
    2. Restricted Formats - openSUSE-Community
    then, if you use 11.1:
    3. Restricted Formats/11.1 - openSUSE-Community

    use one-click-install which is suitable for your desktop (kde or gnome)

    Basically you will add packman repository (these are similar to the ubuntu's "universe" / "multi-verse", etc.) to your list - afterwards you can check other codecs and players there from the software manager - I'd suggest mplayer with smplayer as front-end.

    Also, if you choose vlc I'd suggest you get it from the packman repository instead of the vlc repo since I remember there were some conflicts between the two repositories.

    More info on repositories and how to add / use them:
    Additional YaST Package Repositories - openSUSE

    Add Package Repositories to YaST - openSUSE

    Good luck.

    PS
    The packman repo is available directly in "software repositories" in yast I think, as "community repository".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •