Results 1 to 6 of 6

Thread: No Youtube video on 64bit Mozilla Firefox

  1. #1

    Default No Youtube video on 64bit Mozilla Firefox

    Quick question:

    On 64-bit Firefox I cannot watch videos on youtube. If I turn back to 32bit FF (nothing else changed) I can watch them. What may be the problem?

  2. #2
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: No Youtube video on 64bit Mozilla Firefox

    did you have flash player installed?

    give an output

    Code:
    > rpm -qa|grep flash
    intelGMA3100#amd|radeonHD4200+radeonHD5450@catalyst12.4
    WC5020B,PagePro1480MF,LBP2900,hpCP1510,PHOTO1290,Scanmaker3600,PerfectionV200

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,479
    Blog Entries
    14

    Default Re: No Youtube video on 64bit Mozilla Firefox

    Uninstall 32bit flashplayer, download and install flashplayer 10 64bit (it's alpha I think, but it works great)
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Apr 2009
    Location
    England
    Posts
    19

    Default Re: No Youtube video on 64bit Mozilla Firefox

    In Yast, go to Software/Software Management, and in Search type flash.

    Remove 'libflashsupport' [ I put a lock, never install, personally, since for some reason upgrades often reinstall this which should never have been automatically included in the first place ] and 'pullin-flash-player'. Further remove any other listed files except the flash-player itself --- particularly other flashplayers such as Gnash, since they compete; but it's the the first two files which seem most of the problem ( particularly with sound on flash ).

    In Firefox, go to Preferences/Applications. Make sure 'Shockwave Flash' says 'use Shockwave Flash - in Firefox' [ actually, sometime ago with this problem, I found that toggling between that and 'use Flash Player - Default' would work if the previous setting stopped ]. For nearly all the other media settings I have 'use xine-plugin' I think this may have been chosen back then to force Firefox to use Alsa, but I don't remember: however this set-up works on my machine.

  5. #5

    Default Re: No Youtube video on 64bit Mozilla Firefox

    Code:
    flash-player-10.0.22.87-0.1.1
    I removed the packages you suggested and tweeked the FF preferences and still no videos on Youtube... any more ideas?

    I can't seem to get the 64bit flash version, can anyone point me into the right direction?

  6. #6

    Default Re: No Youtube video on 64bit Mozilla Firefox

    Ok guys it's all done! I downloaded libflashplayer from adobe website, extracted it and I moved it to /usr/lib64/browser-plugins/ and I can finally watch youtube videos! Thanks for the help

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •