Results 1 to 2 of 2

Thread: java-1_6_0-openjdk 64bit,java-1_6_0-openjdk-devel 32bit

  1. #1
    MalcolmDavis NNTP User

    Default java-1_6_0-openjdk 64bit,java-1_6_0-openjdk-devel 32bit

    I understand that for a long time there have been issues with 64bit Linux JDKs, but it is highly confusing that the java-1_6_0-openjdk package installs a 64bit jre, while the java-1_6_0-openjdk-devel package installs a 32bit jdk.

    Also I've tried to follow the instructions on installing 64bit Java on openSUSE 11.1 - openSUSE Forums
    to install directly from a Sun distribution, but I can't figure out how to get a 64bit build from that site. The link from this page goes to a location that says that the build is now final and redirects to a page where there appears to be no mechanism to select 64bit vs 32bit

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: java-1_6_0-openjdk 64bit,java-1_6_0-openjdk-devel 32bit

    Quote Originally Posted by MalcolmDavis View Post
    the java-1_6_0-openjdk-devel package installs a 32bit jdk
    How do you come to that conclusion? AFAICT the programs installed by java-1_6_0-openjdk-devel are 64-bit binaries.

    E.g.

    $ file /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/bin/*
    /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/bin/appletviewer: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.4, dynamically linked (uses shared libs), stripped
    /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/bin/apt: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.4, dynamically linked (uses shared libs), stripped
    /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/bin/extcheck: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.4, dynamically linked (uses shared libs), stripped
    ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •