Results 1 to 8 of 8

Thread: Problem with Ksysguard

  1. #1
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    340

    Default Problem with Ksysguard

    openSUSE 11.1
    Kde 3.5.10

    After it opens, the list in the process table in Ksysguard just flashes and its impossible to select any processes to kill. It wasn't always like that, but it has been for a while now and I don't know what I did if anything to cause it.

    Does anyone know what could cause this kind of behavior and how to fix it?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Problem with Ksysguard

    Same here, I just checked for you. I use kde4 really, but have 3 installed too. Suggest a bug report: https://bugzilla.novell.com/index.cgi
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Problem with Ksysguard

    Start it from a terminal I get:

    Code:
    *** WARNING *** The program 'ksysguard' us                          es the Apple Bonjour compatibility layer of Avahi.
    *** WARNING *** Please fix your application to use the native API of Avahi!
    *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libd                          ns_sd&e=ksysguard>
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    340

    Default Re: Problem with Ksysguard

    Actually I think that that error message has been there ever since the os was installed, and in previous versions of Suse too so I wonder if it has anything to do with this problem.

    When they say port the application that would mean ksysguard anyway wouldn't it? So dealing with avahi itself wouldn't be the problem.

    However not being an expert in these matters I tried replacing everything to do with avahi that I could with Yast but it didn't do any good.

    Still the problem remains.

  5. #5
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Problem with Ksysguard

    Scott Swinyard adjusted his/her AFDB on Tuesday 14 Jul 2009 07:16 to write:

    >
    > Actually I think that that error message has been there ever since the
    > os was installed, and in previous versions of Suse too so I wonder if it
    > has anything to do with this problem.
    >
    > When they say port the application that would mean ksysguard anyway
    > wouldn't it? So dealing with avahi itself wouldn't be the problem.
    >
    > However not being an expert in these matters I tried replacing
    > everything to do with avahi that I could with Yast but it didn't do any
    > good.
    >
    > Still the problem remains.
    >
    >


    Scoot,

    Is it just ksysguard?

    Can you install htop ( is is in the repos )

    This is a conmmandline app that is much more powerful than top and has far
    more capabilities than ksysguard, it has the ability to kill an app in
    different ways such as sighup, sigterm etc..

    I am thinking that it is just a prob with the gui part of ksysguard, maybe
    an incompatible qt or lib or something.

    I have yakuake running all the time and so it is easy to press F12 su to
    root and run htop if I need to monitor procs or kill an unruly app.


    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  6. #6
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    340

    Default Re: Problem with Ksysguard

    I am unfamiliar with htop, but the Xfce4 taskmanager works fine. I just like to have everything working properly, I like ksysguard and it runs off ctrl+esc. etc. etc.

    The program you mention sounds interesting and so does your theory about what may be wrong, however I do not have the technical expertise to follow up on what you suggest. Ksysguard seems to be a part of Kde base and that is all of the information I can find on it in Yast.

  7. #7
    austin78 NNTP User

    Smile Re: Problem with Ksysguard

    It's simple. Just downgrade the kde4-workspace-ksysgard in YaST.
    An everything works fine.

  8. #8

    Default Re: Problem with Ksysguard

    Ksysguard for KDE3 is broken in 11.1, especially with KDE4 packages also installed on the system.

    It is quite unlikely this bug will be fixed any more for KDE3 as official support for it will be dropped soon (IIRC a "complete" KDE3 will no longer be available from OSS-repo in 11.2, only from OBS repos).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •