Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: zypper seg fault

  1. #1

    Cool zypper seg fault

    Since a few days ago, zypper on my OpenSuSE 10.3 64bit system has been very broken :

    Code:
    # zypper refresh ; zypper lu
    Refreshing 'Main Update Repository'
    Segmentation fault
    Segmentation fault
    Rolling back to an earlier version from the update site hasn't helped, and neither has blowing away it's cache (rm -rf /var/cache/zypp/*).

    I've reduced my list of active and auto-refresh repositories down to just this one and obviously it's fairly core to fix :-)
    Any ideas ?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper seg fault

    You could try from su term

    Code:
    rpmdb --rebuilddb
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: zypper seg fault

    No effect, but good idea:
    # rpmdb --rebuilddb
    # zypper refresh
    Repository 'Main Update Repository' is up to date.
    Segmentation fault

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper seg fault

    Post result of

    Code:
    zypper lr
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: zypper seg fault

    Code:
    # zypper lr
    #  | Enabled | Refresh | Type   | Alias                                                             | Name
    ---+---------+---------+--------+-------------------------------------------------------------------+---------------------------
    1  | No      | No      | rpm-md | X11:XGL                                                           | X11:XGL
    2  | No      | No      | rpm-md | suse_mozilla                                                      | suse mozilla
    3  | No      | No      | rpm-md | http://www2.ati.com/suse/10.3                                     | ATI Repository
    4  | No      | No      | rpm-md | Subversion                                                        | Subversion
    5  | No      | No      | rpm-md | http://ftp.skynet.be/pub/packman/suse/10.3/                       | Packman Repository
    6  | No      | No      | yast2  | http://download.opensuse.org/repositories/openSUSE:10.3/standard/ | Main Repository (OSS)
    7  | No      | No      | rpm-md | KDE:Backports                                                     | KDE:Backports
    8  | Yes     | Yes     | rpm-md | http://download.opensuse.org/update/10.3/                         | Main Update Repository
    9  | No      | No      | rpm-md | OpenOffice.org:STABLE                                             | OpenOffice.org:STABLE
    10 | No      | No      | NONE   | Apache                                                            | Apache
    11 | No      | No      | yast2  | openSUSE:10.3:NonFree                                             | openSUSE:10.3:NonFree
    12 | No      | No      | yast2  | openSUSE-10.3-OSS-KDE 10.3                                        | openSUSE-10.3-OSS-KDE 10.3

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper seg fault

    My advice. Try removing them ALL. I know they are disabled.
    Just make a note of what you have.
    Delete everything and add back the main 3, oss, non-oss, updates. And try it again.
    Add others back if needed.

    edit:
    If this fails - try running yast from level 3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: zypper seg fault

    I had this exact same issue removing each one:

    Code:
    # zypper rr  "http://ftp.skynet.be/pub/packman/suse/10.3/"
    Segmentation fault
    # zypper rr  "http://ftp.skynet.be/pub/packman/suse/10.3/"
    Repository not found by given alias or URL.
    I'm now using 'software repositories' from the YaST control panel to add in the updates repo,. I'll then update (if req) before putting the others back.

    Cheers - something was obviously confused deep in the bowels somewhere.

  8. #8

    Default Re: zypper seg fault

    Bah, hasn't helped :-(

    Code:
    # zypper refresh
    Refreshing '10.3 updates'
    Segmentation fault

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: zypper seg fault

    Have you tried managing from the Yast GUI?

    Or as I suggested from runlevel 3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Camalen NNTP User

    Default Re: zypper seg fault

    chivertont wrote:

    > Bah, hasn't helped :-(
    >
    >
    > Code:
    > --------------------
    > # zypper refresh
    > Refreshing '10.3 updates'
    > Segmentation fault
    > --------------------


    Check your version of libcurl4:

    ***
    hpc02@stthpc:~> rpm -qa | grep libcurl4
    libcurl4-7.16.4-16.4
    ***

    Greetings,

    --
    Camalen

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •