Every day I am told that there is an update for yast2-backup. When I tell it to do the update, it says:

Could not remove a protected system package.
Removing a system package is not allowed.

If I click the more details arrow I get:

Subprocess failed. Error: RPM failed: error: package yast2-backup-2.17.3-1.1.noarch is not installed

If I try to update through the Yast online update, it gives me the same message.

I tried to remove and reinstall through yast software management, but as soon as I click on the package, Software Managment closes and I get an error message that says:

y2base: /usr/include/boost/intrusive_ptr.hpp:149: T* boost::intrusive_ptr<T>:perator->() const [with T = const zypp::target::rpm::RpmHeader]: Assertion `p_ != 0' failed.
YaST got signal 6 at YCP file PackagesUI.ycp:240
/sbin/yast2: line 440: 17199 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

I have been playing with opensuse for a few years now, and I never ran into a problem I couldnt fix by removing and reinstalling. I even tried to install a newer version of the file yast2-backup from rpmbone. It looked like it installed (the window closed, no errors), But the next day the update showed the yast2-backup file again.

I got really desperate and reinstalled yast. No help there either. The system runs fine, but if there is something wrong, it may affect me in the future. Any ideas would be appreciated--RB BTW I didnt add the smiley right in the middle of the fault, it did it by its self. Ill look into that later..