Hi Folks

I'm new to openSuse so I'm probably making a foolish mistake
I'm trying to upgrade firefox to 3.5
I added the repository to yast
Code:
http://download.opensuse.org/repositories/mozilla/openSUSE_11.1]Index of /repositories/mozilla/openSUSE_11.1
and when I let it search I get this

http://www.drobbins.net/yast.png

this is for the 64 bit flavor
any ideas what I may be doing wrong?

Thanks
Dave