Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: YaST segfaults when installing Qt Creator

  1. #1

    Default YaST segfaults when installing Qt Creator

    I'm using openSUSE 11.1.

    I've been trying to install Qt Creator from here: Software.openSUSE.org. I at first just installed the one at the top of the list, which happens to be the Qt 4.5 one. It wouldn't run so I uninstalled it and removed the repo it added. I then tried to install the other one, and now whenever I try to install either version, neither installs and I get a segfault message from YaST. This is the message:
    Code:
    YaST got signal 11 at YCP file Wizard.ycp:36
    /sbin/yast2: line 437: 12646 Segmentation fault      $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    This is in an xmessage window, so I had to type it all out, I can't copy+paste from it.

    Anyways, I did some searching after this, and I found lots of "you need to downgrade your qt apps". But I've already removed the qt45 repo, and when I try to upgrade my stuff, there are none to upgrade.

    Thanks,
    Jordy

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: YaST segfaults when installing Qt Creator

    In Yast - Software Management Filter by repo
    select system
    scroll thru and find all red color QT packages and click them, that should roll them back
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: YaST segfaults when installing Qt Creator

    Quote Originally Posted by caf4926 View Post
    In Yast - Software Management Filter by repo
    select system
    scroll thru and find all red color QT packages and click them, that should roll them back
    Unfortunately, this did not work. There was only one of them, and afterwards trying to install from software.opensuse.org still gave segfaults.

    I can still install from the repos, if that means anything, I just can't install anything from software.opensuse.org

    Also, this is a fresh install. Since I don't have any data on here that I really want to keep, should I just do a reinstall and not try to install Qt Creator?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: YaST segfaults when installing Qt Creator

    I can still install from the repos, if that means anything, I just can't install anything from software.opensuse.org
    You don't really make sense. Sorry.

    Open a terminal and post the result of this:

    Code:
    zypper lr --details
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: YaST segfaults when installing Qt Creator

    Quote Originally Posted by caf4926 View Post
    You don't really make sense. Sorry.

    Open a terminal and post the result of this:

    Code:
    zypper lr --details
    Sorry if I don't make sense, I'm new to OpenSUSE. I come from Ubuntu and Arch.

    Results of zypper lr --details:
    Code:
    # | Alias                   | Name                    | Enabled | Refresh | Priority | Type   | URI                                                                                | Service
    --+-------------------------+-------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | NVIDIA Repository       | NVIDIA Repository       | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/11.1                                           |
    2 | home:pantsgolem:qtcurve | home:pantsgolem:qtcurve | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/pantsgolem:/qtcurve/openSUSE_11.1/ |
    3 | openSUSE 11.1-0         | openSUSE 11.1-0         | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                            |
    4 | repo-debug              | openSUSE-11.1-Debug     | No      | Yes     |  100     | NONE   | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                     |
    5 | repo-non-oss            | openSUSE-11.1-Non-Oss   | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                       |
    6 | repo-oss                | openSUSE-11.1-Oss       | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                           |
    7 | repo-source             | openSUSE-11.1-Source    | No      | Yes     |  100     | NONE   | http://download.opensuse.org/source/distribution/11.1/repo/oss/                    |
    8 | repo-update             | openSUSE-11.1-Update    | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1/                                          |

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: YaST segfaults when installing Qt Creator

    First if possible check in Yast - Software Management
    Filter by repos and select
    home-antsgolem:qtcurve

    If there are any packages installed from there, delete them.
    When that's done - delete that repo.

    If you really want those packages I can give you a repo to add, but first - Tell us if you use kde3 or kde4?

    In the mean time, open a terminal and become su

    Now do this:
    Code:
    zypper ref
    Now:
    Code:
    zypper dup
    Logout and back in
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: YaST segfaults when installing Qt Creator

    Done.

    I'd like the repo (qtcurve), but really anything that will make my GTK apps blend in with my Qt apps will make me happy.

    I am using KDE 4. I generally use GNOME, but I thought with my new installation I'd give it a try.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: YaST segfaults when installing Qt Creator

    Quote Originally Posted by Jordy_D View Post
    Done.

    I'd like the repo (qtcurve), but really anything that will make my GTK apps blend in with my Qt apps will make me happy.

    I am using KDE 4. I generally use GNOME, but I thought with my new installation I'd give it a try.
    The repos to add are:

    kde4 desktop from Build service will give some updates
    Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1

    kde4 community
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1
    I'm not certain it will provide the GTk stuff though
    =============
    FYI.
    The way to install packages is with Software Management. Don't use the OneClicks from webpin. It's OK to find apps, but add repo's manually - The repo's can be found here:
    Index of /repositories
    Bookmark it

    is your system working any better yet?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: YaST segfaults when installing Qt Creator

    Thanks.

    Is it safe to add the repo for Qt Creator and install it through that?

    Should I uninstall my NVidia repos and add the one in the index, or is that fine the way it is?

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: YaST segfaults when installing Qt Creator

    Keep Nvidia as it is.

    What is the url of the QT repo you want to add?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •