Results 1 to 5 of 5

Thread: kmail and libgpgme on 11.2 M3

  1. #1

    Question kmail and libgpgme on 11.2 M3

    Hi all,

    my next problem with the new milestone 3.

    I cannot use kmail anymore - everytime i want to send a mail or change my identity the program crashes and leaves the following error message in the console.

    The people in #kde-devel know the problem i apparently - the package would be broken...

    How can i fix that problem?


    Error:
    kmail: relocation error: /usr/lib64/libgpgme++-pthread.so.2: symbol gpgme_check_version_internal, version GPGME_1.1 not defined in file libgpgme-pthread.so.11 with link time reference

    versions:
    kmail Version: 4.2.95-136.4 from opensuse factory
    libgpgme Version: 1.1.8-4.2 from opensuse-11.2 oss
    1) Lenovo T61 with Nvidia Quadro NVS 140M and Intel AGN - on OpenSuSE 11.2 with KDE 4.3
    2) Desktop PC with Nvidia 8800 GTS, G15 Keyboard and LAN - on OpenSuSE 11.1 with KDE 4.2

  2. #2
    Graham P Davis NNTP User

    Default Re: kmail and libgpgme on 11.2 M3

    saLOUt wrote:

    > my next problem with the new milestone 3.
    >
    > I cannot use kmail anymore - everytime i want to send a mail or change
    > my identity the program crashes and leaves the following error message
    > in the console.


    You are not alone. Kmail also crashes for me when attempting to send a mail.
    Also Kmail is now detached from Kontact - opens in its own window - and I
    remember having this happen a few years ago but can't recall how to fix it.


    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  3. #3
    Graham P Davis NNTP User

    Default Re: kmail and libgpgme on 11.2 M3

    Graham P Davis wrote:


    > You are not alone. Kmail also crashes for me when attempting to send a

    mail.
    > Also Kmail is now detached from Kontact - opens in its own window - and I
    > remember having this happen a few years ago but can't recall how to fix

    it.
    >


    Kmail re-attached itself after I'd had a good night's sleep.

    Found another problem with it. It also crashes when adding a new identity.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  4. #4
    Xandersoft NNTP User

    Wink Re: kmail and libgpgme on 11.2 M3

    here my fix option:

    you have to refresh the libgpgme11 libery.
    this fix your problem.

    alternativ you can search for "GPGME_1.1" with following options for search:

    RPM "Provides" and RPM "Requiers"

    than refresh all Packages are be list.

    greetz
    Alex

  5. #5
    cancerlynx NNTP User

    Cool Re: kmail and libgpgme on 11.2

    Just loaded opensuse 11.2
    Kmail
    Version 1.12.2
    Using KDE 4.3.1 (KDE 4.3.1) "release
    I have checked with my ISP and all the settings are correct and reported this as bug to kmail

    to get messages
    I had to change to no encryption from ssl

    It will not send messages
    when I try I get this message
    Transport <domain> is invalid

    reloaded libgpgme and nothing!
    should I just drop back to opensuse 11
    11.1 - sax kept failing

    on a Lenovo T61 laptop running only suse

    so *annoying*

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •