Results 1 to 9 of 9

Thread: "Windows" key in KDE 3

  1. #1

    Default "Windows" key in KDE 3

    I've a problem with openSUSE 11.1 (freshly installed and updated). I want "WIN" key to be "META" key (modifier), but it somehow assigned by default to run "K Menu" applet. I cannot assign anything else to WIN + smth combination, it always runs K-Menu.

    I was trying to find where I could disable it, but failed. Of course I checked "Keyboard Shortcuts" in KDE settings, but there I have only Alt+1 for "K Menu".

    Searching the web, I've found many ways how to ENABLE it, but seemingly they all are different from the way used in 11.1.

    It is really annoying, because on other KDE 3 machine with openSUSE 11.0 (updated from 10.3), I don't have such problem.

    I like having a lot of different shotcuts with "WIN" key, so thay don't interfere with Ctrl and/or Alt key shortcuts. I don't want having WIN key solely devoted to "K-Menu"!!!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: "Windows" key in KDE 3

    The main way to set shortcut keys in kde4 is to use menu editor, go the the app you want. Like this eg:
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: "Windows" key in KDE 3

    Dear caf4926, as you may have noticed, the topic title is :""Windows" key in KDE 3".

    May be I was not clear enough: I want to disable openSUSE 11.1 KDE3 builtin shortcut on "win" key and make it just an ordinary modifier.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: "Windows" key in KDE 3

    I'll login to my kde3 and see
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: "Windows" key in KDE 3

    I can't see a way to do this. I seem to recall a thread about this not too long ago. Sorry.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Camalen NNTP User

    Default Re: "Windows" key in KDE 3

    Vayun wrote:

    > I've a problem with openSUSE 11.1 (freshly installed and updated). I
    > want "WIN" key to be "META" key (modifier), but it somehow assigned by
    > default to run "K Menu" applet. I cannot assign anything else to WIN +
    > smth combination, it always runs K-Menu.
    >
    > I was trying to find where I could disable it, but failed. Of course I
    > checked "Keyboard Shortcuts" in KDE settings, but there I have only
    > Alt+1 for "K Menu".


    Open a terminal and type:

    ***
    cat ~/.kde/share/config/khotkeysrc | grep "Win+"
    ***

    To find out any reference on this key combo, if any.

    You can also take a look in the whole file.

    Greetings,

    --
    Camalen

  7. #7

    Default Re: "Windows" key in KDE 3

    Quote Originally Posted by Camalen View Post
    Open a terminal and type:

    ***
    cat ~/.kde/share/config/khotkeysrc | grep "Win+"
    ***

    To find out any reference on this key combo, if any.

    You can also take a look in the whole file.
    There is only one there:
    Code:
    > cat ~/.kde/share/config/khotkeysrc | grep "Win+"
    Comment=After pressing Win+E (Tux+E), WWW browser will be launched and it will open http://www.kde.org . You may run all kind of commands you can run in minicli (Alt+F2).
    Key=Win+E
    Win+Key combo just does not work, because as soon you press 'WIN' K-Menu popups and the next key already go in it.

  8. #8
    Camalen NNTP User

    Default Re: "Windows" key in KDE 3

    Vayun wrote:

    > Camalen;2006943 Wrote:
    >>
    >> Open a terminal and type:
    >>
    >> ***
    >> cat ~/.kde/share/config/khotkeysrc | grep "Win+"
    >> ***
    >>
    >> To find out any reference on this key combo, if any.
    >>
    >> You can also take a look in the whole file.
    >>

    > There is only one there:
    >
    > Code:
    > --------------------
    > > cat ~/.kde/share/config/khotkeysrc | grep "Win+"

    > Comment=After pressing Win+E (Tux+E), WWW browser will be launched and
    > it will open http://www.kde.org . You may run all kind of commands you
    > can run in minicli (Alt+F2). Key=Win+E
    > --------------------
    >
    >
    > Win+Key combo just does not work, because as soon you press 'WIN'
    > K-Menu popups and the next key already go in it.


    Does it happen when you login with all users or just with your standard one?

    In fact, it is quite difficult to get just one key (i.e., windows key)
    associated with any event as the standard way to achieve this is using a
    combination of two keys (Win+key) :-?

    Look:

    5.7. How do I use the Windows key to open the K menu?
    http://docs.kde.org/kde3/en/kdebase/...html#id2532341

    Review your options under kde control center / regional and accessibility /
    keyboard layout ("xkb options" tab) and keyboard shortcuts ("keyboard
    shortcut layout" tab).

    Greetings,

    --
    Camalen

  9. #9

    Default Re: "Windows" key in KDE 3

    Yes I know that it should be difficult. Your hint to try a new user helped.

    I've found the source of the problem.

    It was Compiz plugin Workarounds, which has innocent looking option "Show main menu" and it is by default "Meta_L"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •