Results 1 to 4 of 4

Thread: F-Spot "Could not lock decive error in GNOME

  1. #1

    Default F-Spot "Could not lock decive error in GNOME

    Both F-Spot and digiKam return the same results in GNOME when trying to connect to my Canan A590IS camera. Under KDE4 they both work just fine. When I plug in the camera under GNOME it comes up on the desktop and I can view the camera contents Nautilius. I am running SUSE11.1 and have tried reinstalling the software with no luck. I really want to use GNOME is there any help? BTW:Novice suse user...

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: F-Spot "Could not lock decive error in GNOME

    Quote Originally Posted by kencm View Post
    Both F-Spot and digiKam return the same results in GNOME when trying to connect to my Canan A590IS camera. Under KDE4 they both work just fine. When I plug in the camera under GNOME it comes up on the desktop and I can view the camera contents Nautilius. I am running SUSE11.1 and have tried reinstalling the software with no luck. I really want to use GNOME is there any help? BTW:Novice suse user...
    Return the same results, but what? You can't connect/browse them?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: F-Spot "Could not lock decive error in GNOME

    Thanks for taking the time to reply. I resolved the problem. When I plug the camera in GNOME mounts it as a USB device so the simple solution is to unmount the camara and then all works fine. This is a GNOME issue since all camara software does the samt thing. Can't mount the same device twice, should have realized that. Now it would be nice to figure a way to keep the system from mounting a camera, got to look into that, easy enough in KDE - any help there?

  4. #4
    steve_cr NNTP User

    Default Re: F-Spot "Could not lock decive error in GNOME

    I get the same problem with my Canon A510. I can browse the cameras folders and images using Nautilus but I can't get F-Spot to read the device. The error message is:
    "Error connecting to camera
    Received error "Could not lock the device" while connecting to the camera"
    So I close F-Spot, end my Nautilus session which leaves me with the "Canon, Inc. PowerShot A510(normal mode) / PowerShot A510 (PTP mode)" icon on the desktop. Can someone explain to me how to use F-Spot to access the images on the camera?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •