Results 1 to 6 of 6

Thread: Apache compilation

  1. #1
    pH30 NNTP User

    Default Apache compilation

    Hello, I'm looking for help to compile an old Apache 2.0.63 on OpenSuse 10.3 that I never did before.

    Last year, I installed a mixed 2.0.54 from RPM of Suse10 on this release to be compatible with a software. Now, I must upgrade it to another old version.

    I read the Apache doc, but I still have some troubles.
    I try this :
    sh configure \
    --prefix=/etc/apache2/ \
    --enable-rewrite \
    --enable-module \
    --with-suexec-docroot=/srv/www/htdocs/ \
    --with-apr=/usr/bin/apr-config \
    --with-apr-util=/usr/bin/apu-config

    The errors of the compilation command :
    ...
    configure: line 5248: /usr/share/apache2/build/libtool: No such file or directoryconfigure
    ...
    configure: line 7373: ./build/mkdir.sh: Permission denied
    ...
    configure: line 18942: build/PrintPath: Permission denied
    configure: line 18969: ./build/get-version.sh: Permission denied
    ...

    The result of make command:
    /bin/sh: /usr/share/apache2/build/libtool: No such file or directory
    make[3]: *** [maketables.lo] Error 127
    make[3]: Leaving directory `/usr/src/httpd-2.0.63/srclib/pcre'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/usr/src/httpd-2.0.63/srclib/pcre'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/httpd-2.0.63/srclib'
    make: *** [all-recursive] Error 1

    Do I must delete the installed version on my system before compiling a new one ?
    I'm lost... Could someone tell me how to do ???

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Apache compilation

    Quote Originally Posted by pH30
    Hello, I'm looking for help to compile an old Apache 2.0.63 on OpenSuse
    10.3 that I never did before.

    Last year, I installed a mixed 2.0.54 from RPM of Suse10 on this
    release to be compatible with a software. Now, I must upgrade it to
    another old version.

    I read the Apache doc, but I still have some troubles.
    I try this :
    sh configure \
    --prefix=/etc/apache2/ \
    --enable-rewrite \
    --enable-module \
    --with-suexec-docroot=/srv/www/htdocs/ \
    --with-apr=/usr/bin/apr-config \
    --with-apr-util=/usr/bin/apu-config

    The errors of the compilation command :
    ...
    configure: line 5248: /usr/share/apache2/build/libtool: No such file or
    directoryconfigure
    ...
    configure: line 7373: ./build/mkdir.sh: Permission denied
    ...
    configure: line 18942: build/PrintPath: Permission denied
    configure: line 18969: ./build/get-version.sh: Permission denied
    ...

    The result of make command:
    /bin/sh: /usr/share/apache2/build/libtool: No such file or directory
    make[3]: *** [maketables.lo] Error 127
    make[3]: Leaving directory `/usr/src/httpd-2.0.63/srclib/pcre'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/usr/src/httpd-2.0.63/srclib/pcre'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/httpd-2.0.63/srclib'
    make: *** [all-recursive] Error 1

    Do I must delete the installed version on my system before compiling a
    new one ?
    I'm lost... Could someone tell me how to do ???

    Thanks

    Hi
    Rather than using sh, use ./ and try the command all on one line.
    Code:
    ../configure --prefix=/etc/apache2/ --enable-rewrite --enable-module --with-suexec-docroot=/srv/www/htdocs/ --with-apr=/usr/bin/apr-config --with-apr-util=/usr/bin/apu-config
    Also, if you don't finish the confiure stage properly, there isn't any
    point running make

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.23-0.1-default
    up 4 days 21:37, 2 users, load average: 0.17, 0.24, 0.28
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  3. #3
    pH30 NNTP User

    Default Re: Apache compilation

    Thanks for your reply.

    I use as you tell me :

    ./configure --prefix=/etc/apache2/ --enable-rewrite --enable-module --with-suexec-docroot=/srv/www/htdocs/ --with-apr=/usr/bin/apr-config --with-apr-util=/usr/bin/apu-config

    And create a symbolic link for libtool :

    ln -s /usr/bin/libtool /usr/share/apache2/build/libtool

    Then without error in configure command I get this message about ldap with make :

    In file included from exports.c:33:
    /usr/include/apache2/apr_ldap.h:126:18: error: lber.h: No such file or directory
    /usr/include/apache2/apr_ldap.h:127:18: error: ldap.h: No such file or directory
    In file included from exports.c:101:
    /usr/src/httpd-2.0.63/include/util_ldap.h:72: error: 'LDAP_DEREF_NEVER' undeclared here (not in a function)
    /usr/src/httpd-2.0.63/include/util_ldap.h:73: error: 'LDAP_DEREF_SEARCHING' undeclared here (not in a function)
    /usr/src/httpd-2.0.63/include/util_ldap.h:74: error: 'LDAP_DEREF_FINDING' undeclared here (not in a function)
    /usr/src/httpd-2.0.63/include/util_ldap.h:75: error: 'LDAP_DEREF_ALWAYS' undeclared here (not in a function)
    /usr/src/httpd-2.0.63/include/util_ldap.h:80: error: expected specifier-qualifier-list before 'LDAP'
    make[2]: *** [exports.lo] Error 1
    make[2]: Leaving directory `/usr/src/httpd-2.0.63/server'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/httpd-2.0.63/server'
    make: *** [all-recursive] Error 1

    Any idea ???

  4. #4
    pH30 NNTP User

    Default Re: Apache compilation

    After the install of ldap-devel I get :

    collect2: ld returned 1 exit status
    make[2]: *** [htpasswd] Error 1
    make[2]: Leaving directory `/usr/src/httpd-2.0.63/support'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/httpd-2.0.63/support'
    make: *** [all-recursive] Error 1

    Well, well

  5. #5
    pH30 NNTP User

    Default Re: Apache compilation

    OK I finish the compilation, my first one.
    make & make install ran correctly.
    Then I modify httpd.conf as I need

    but when I try to test :

    /usr/sbin/apachectl start
    /usr/sbin/httpd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

    Something wrong with ssl even if all packages are installed. Any idea ???

  6. #6
    pH30 NNTP User

    Default Re: Apache compilation

    OK I didn't use the right command. All the files are in /etc/apache2 now.

    /etc/apache2/bin/apachectl start runs fine, well, I'm not sure because it doesn't tell OK as the rcapache2 command.

    I don't have connexion to my server by mozilla, I'll looking for the logs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •