Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: GRUB Loading Stage 2..Problem

  1. #1

    Default GRUB Loading Stage 2..Problem

    I've just installed openSUSE 11.1 everything was going good, then I had to reboot and it wouldn't boot, would just get suck on "GRUB loading Stage2.." then I tried system check and it found boot problem, but it didn't fix it, so I re-installed openSUSE and still the same problem.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: GRUB Loading Stage 2..Problem

    You really need to provide information about your install.

    A su terminal and do:

    Code:
    fdisk -l
    That will show all your disks and partitions. Paste it here.
    Try and explain what you think you have done. eg; which partition is which, where you installed grub etc...?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: GRUB Loading Stage 2..Problem

    I installed it on one partition, and I don't get what you mean by where I installed grub.

    fdisk -l:

    Code:
    Disk /dev/sda: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16055 * 512 = 8225280
    Disk identifier: 0x1549f232
    
    Device Boot   Start   End    Blocks   Id   System
    /dev/sda1 *       1  37784 303499948+ 83   Linux
    /dev/sda2     37785  38913   9068692+  5   Extended
    /dev/sda5     37785  38913   9068661  82   Linux swap / Solaris
    
    
    Disk /dev/sdb: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16055 * 512 = 8225280
    Disk identifier: 0xf7ce1580
    
    Device Boot   Start   End    Blocks   Id   System
    /dev/sdb1 *       1  37777 303443721  83   Linux
    /dev/sdb2     37778  38913   9124920  5    Extended
    /dev/sdb5     37778  38913   9124888+ 82   Linux swap / Solaris
    

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: GRUB Loading Stage 2..Problem

    You have 2 HD's sda and sdb
    which HD is SUSE, what is on the other?

    Do you understand about HD boot order in the BIOS?
    Have you changed boot order since you installed?
    Have you changed the boot menu in Yast?
    Have you run online update in Yast

    You can boot an installed suse system with the install dvd or if you used a cd you can use super grub disk:
    see here for more info HowTo Boot into openSUSE when it won't Boot from the Grub Code on the Hard Drive

    Did you install grub to the MBR and of which HD?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: GRUB Loading Stage 2..Problem

    Quote Originally Posted by caf4926 View Post
    You have 2 HD's sda and sdb
    which HD is SUSE, what is on the other?

    Do you understand about HD boot order in the BIOS?
    Have you changed boot order since you installed?
    Have you changed the boot menu in Yast?
    Have you run online update in Yast

    You can boot an installed suse system with the install dvd or if you used a cd you can use super grub disk:
    see here for more info HowTo Boot into openSUSE when it won't Boot from the Grub Code on the Hard Drive

    Did you install grub to the MBR and of which HD?

    Sude is sda, and I think sdb is Ubuntu 7.10 I installed long time ago.

    Not really.
    No.
    No.
    Yes.

    I did what it said, but after it says "Welcome to openSUSE 11.1 - Kernel 2.6.27.7.9-default (tty1)."

    Then asks me to log in, once done just stays in tty asking for a command.

    Also, in the tty it says
    Code:
    FATAL: Could not load /lib/modules/2.6.27.7-9-default/modules.dep: No such file or directory
    iptables v1.4.2-rc1: can't initialize iptables table 'filter': iptables who? (do you need to insmod?)
    Perhaps iptables or oyur kernel needs to be upgraded.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: GRUB Loading Stage 2..Problem

    Do you have a live cd?
    Any Distro will do. Boot it and go to sda1. If it's not mounted, mount it and then go to sda1 and in the folder tree go to:
    /boot/grub/menu.lst

    Copy it and paste it here:

    I am correct in thinking you do get the green suse boot menu, but then it fails when you try to boot the OS.
    Incidentally, is your other OS in the menu? And if yes, does it boot?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: GRUB Loading Stage 2..Problem

    No, I do not have a live cd.
    Well actually, my other OS doesn't work and it's not even in the menu.

  8. #8

    Default Re: GRUB Loading Stage 2..Problem

    Bit confused how you got fdisk output but seeming as you did..

    You could try the repair of the install media if you have the full dvd(Maybe on the CD to).

    If that doesn't work, then after su use terminal yast => system => bootloader and install it from there.

    Otherwise you may have to use command line grub and install with that. After su try grub-install it should work.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  9. #9

    Default Re: GRUB Loading Stage 2..Problem

    Quote Originally Posted by FeatherMonkey View Post
    Bit confused how you got fdisk output but seeming as you did..

    You could try the repair of the install media if you have the full dvd(Maybe on the CD to).

    If that doesn't work, then after su use terminal yast => system => bootloader and install it from there.

    Otherwise you may have to use command line grub and install with that. After su try grub-install it should work.
    With the CD, you can go in Escape mode and it takes you to the tty.

    So do you want me to re-install su? Since, I can't boot into it for boot error, I should re-install su and manually install the bood loader? I can get in tty if there is a way to install it from there.

    Also, everytime I try to repair, everything goes great but after it opens up the linux kernel saying "there was an error during the installation"

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: GRUB Loading Stage 2..Problem

    I refer you to my post @ #4
    if you don't have the dvd you could download super grub disk
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •