Results 1 to 6 of 6

Thread: Keyboard connected but can't type

  1. #1

    Default Keyboard connected but can't type

    Hello all:

    This is a new one, for me anyway.

    I have an older e-machine running 11.1 and out of the blue, I can no longer type into any app.

    Naturally, thinking it was a defective keyboard I swapped it out, no luck. Thinking it might be the plug on the motherboard, I use a USB keyboard, still no luck.

    I restarted the machine each time. Then the light bulb went off, when I restart the computer I have to type in my password. Restarting again, sure enough, I can type in my password but once in I can't type in any app., Thunderbird, Firefox, Kwrite, OOword, ...

    How is this possible - and more importantly, how do I fix it?

    Thanks,
    Kevin

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Keyboard connected but can't type

    Boot to runlevel 3
    You do that from the boot menu, clear boot arguments and just type: 3
    login as user at the CLI
    then go su

    start yast with: yast

    It's keyboard navigated so hope it works. Go to hardware and try and configure the keyboard.
    When done:
    reboot
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Keyboard connected but can't type

    Well that worked - mostly, thanks.

    I've never had a reason to reconfig a keyboard. While usable now, you have to press and hold the key (for about a .5 - 1 sec.) before it registers.

    I see a way to change the repeat rate and delay but not a way to change the initial the rate. I'll play with that but if you have a suggestion,...

    Thanks again,
    Kevin

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Keyboard connected but can't type

    It might be more related to running processes hogging things.
    Disable beagle if you have it and either stop it from starting at boot or remove it completely.
    What spec have you. RAM?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    45

    Default Re: Keyboard connected but can't type

    Are you running KDE 4.2.4? I and some other people on the Net have found that 'slow keys' can randomly get enabled in 4.2.4. It's under Configure Desktop, Accessibility.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: Keyboard connected but can't type

    Please check this as well:
    The keyboard configured in Yast should be the same as the one configured in KDE !!. I changed to one of these Apple keyboards and had this problem yesterday. After setting it in Yast it did not work as it should (very slow response, up to 15 minutes before character appeared, so looked dead). By mouse I changed the keyboard in the systemsettings as well, logged out and in, problem gone.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •