Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Calling wicd users - need help with problem

  1. #1
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Calling wicd users - need help with problem

    I use wicd for my network management and am quite happy with it except for a few annoyances. I've posted my problems on the forum over at wicd but am not getting much response so am hoping someone here may be able to help.

    I'm using opensuse 11.1, KDE4.2.4 and installed wicd 1.60 from the suse repo.
    Everything seems to work fine apart from:
    1) Every time I boot up wicd is asking for my root password. I've done a search and found someone experiencing a similar problem but that was some time ago with version 1.5 so I'm not sure the solution applies any more.
    Output from ls -ahl /etc/init.d/wicd

    Code:
    -rwxr-xr-x 1 root root 1.2K 2009-06-08 23:26 /etc/init.d/wicd
    Output from sudo cat /etc/init.d/wicd

    Code:
    #! /bin/sh                                                   
    
    ### BEGIN INIT INFO
    # Provides:       wicd-daemon
    # Required-Start: dbus       
    # Required-Stop:  $null      
    # Default-Start:  3 4 5      
    # Default-Stop:              
    # Description: wicd, a wired and wireless connection manager.
    ### END INIT INFO                                            
    
    WICD_BIN=/usr/sbin/wicd
    test -x $WICD_BIN || exit 5
    
    . /etc/rc.status
    rc_reset        
    
    case "$1" in
            start)
                    checkproc $WICD_BIN
                    if [ $? = 0 ]; then
                            echo -n "wicd already running"
                            rc_status -v                  
                            rc_exit                       
                    fi                                    
                    echo -n "Starting wicd"               
                    startproc $WICD_BIN                   
                    rc_status -v                          
                    ;;                                    
            stop)                                         
                    echo -n "Shutting down wicd"          
                    killproc -TERM $WICD_BIN              
                    rc_status -v                          
                    ;;                                    
            restart)                                      
                    $0 stop                               
                    $0 start
                    rc_status
                    ;;
            status)
                    echo -n "Checking for wicd: "
                    checkproc $WICD_BIN
                    rc_status -v
                    ;;
            *)
                    echo "Usage: $0 {start|stop|status|restart}"
                    exit 1
                    ;;
    esac
    Output of ps -ef | grep wicd

    Code:
    root      5356     1  0 07:16 ?        00:00:12 python -O /usr/lib/wicd/wicd-daemon.py
    root      5361  5356  0 07:16 ?        00:00:04 /usr/bin/python -O /usr/lib/wicd/monitor.py
    {my username}     5386  5263  0 07:16 ?        00:00:02 python -O /usr/lib/wicd/wicd-client.py
    {my username}    12723  6542  0 08:16 pts/1    00:00:00 grep wicd
    2) Every time wicd starts (after I've entered the root password) I get an error saying "Could not connect to D-bus interface. Check wicd log for errors" but wicd does connect to the network despite this. Also the tray icon doesn't start unless I Alt-F2>wicd-client.
    Here is a copy of a wicd log file immediately after a cold boot and starting wicd. A few warnings in there.

    Code:
    2009/06/29 07:48:31 :: wicd initializing...
    2009/06/29 07:48:31 :: ---------------------------
    2009/06/29 07:48:31 :: wicd is version 1.6.0 410
    2009/06/29 07:48:31 :: setting backend to external
    2009/06/29 07:48:31 :: trying to load backend external
    2009/06/29 07:48:31 :: successfully loaded backend external
    2009/06/29 07:48:32 :: WARNING: No path found for pump
    2009/06/29 07:48:32 :: WARNING: No path found for mii-tool
    2009/06/29 07:48:32 :: WARNING: No path found for gksudo
    2009/06/29 07:48:32 :: WARNING: No path found for ktsuss
    2009/06/29 07:48:32 :: WARNING: No path found for resolvconf
    2009/06/29 07:48:32 :: trying to load backend external
    2009/06/29 07:48:32 :: successfully loaded backend external
    2009/06/29 07:48:32 :: WARNING: No path found for pump
    2009/06/29 07:48:32 :: WARNING: No path found for mii-tool
    2009/06/29 07:48:32 :: WARNING: No path found for gksudo
    2009/06/29 07:48:32 :: WARNING: No path found for ktsuss
    2009/06/29 07:48:32 :: WARNING: No path found for resolvconf
    2009/06/29 07:48:32 :: Automatically detected wireless interface wlan0
    2009/06/29 07:48:32 :: setting wireless interface wlan0
    2009/06/29 07:48:32 :: automatically detected wired interface eth0
    2009/06/29 07:48:32 :: setting wired interface eth0
    2009/06/29 07:48:32 :: setting wpa driver wext
    2009/06/29 07:48:32 :: setting use global dns to False
    2009/06/29 07:48:32 :: setting global dns
    2009/06/29 07:48:32 :: global dns servers are None None None
    2009/06/29 07:48:32 :: domain is None
    2009/06/29 07:48:32 :: search domain is None
    2009/06/29 07:48:32 :: setting automatically reconnect when connection drops True
    2009/06/29 07:48:32 :: found wired_connect_mode in configuration 1
    2009/06/29 07:48:32 :: Setting dhcp client to 0
    2009/06/29 07:48:32 :: Wireless configuration file found...
    2009/06/29 07:48:32 :: Wired configuration file found...
    2009/06/29 07:48:32 :: chmoding configuration files 0600...
    2009/06/29 07:48:32 :: chowning configuration files root:root...
    2009/06/29 07:48:32 :: Using wireless interface...wlan0
    2009/06/29 07:48:32 :: Using wired interface...eth0
    2009/06/29 07:48:32 :: scanning start
    2009/06/29 07:48:32 :: ifconfig wlan0 up
    2009/06/29 07:48:32 :: iwlist wlan0 scan
    2009/06/29 07:48:35 :: scanning done
    2009/06/29 07:48:35 :: found 1 networks:
    2009/06/29 07:48:35 :: found afterscript in configuration None
    2009/06/29 07:48:35 :: found psk in configuration {followed by long string of alphanumeric}
    2009/06/29 07:48:35 :: found ip in configuration None
    2009/06/29 07:48:35 :: found disconnectscript in configuration None
    2009/06/29 07:48:35 :: found dns_domain in configuration None
    2009/06/29 07:48:35 :: found netmask in configuration None
    2009/06/29 07:48:35 :: found key in configuration 5un5eakerpr0pertie5
    2009/06/29 07:48:35 :: found gateway in configuration None
    2009/06/29 07:48:35 :: found use_global_dns in configuration 0
    2009/06/29 07:48:35 :: found dns3 in configuration None
    2009/06/29 07:48:35 :: found dns1 in configuration None
    2009/06/29 07:48:35 :: found use_settings_globally in configuration 0
    2009/06/29 07:48:35 :: found use_static_dns in configuration 0
    2009/06/29 07:48:35 :: found dns2 in configuration None
    2009/06/29 07:48:35 :: found beforescript in configuration None
    2009/06/29 07:48:35 :: found enctype in configuration wpa
    2009/06/29 07:48:35 :: found automatic in configuration True
    2009/06/29 07:48:35 :: found search_domain in configuration None
    2009/06/29 07:48:37 :: ifconfig eth0
    2009/06/29 07:48:37 :: ifconfig wlan0
    2009/06/29 07:48:37 :: iwconfig wlan0
    2009/06/29 07:48:37 :: GetCurrentNetworkID: Returning -1, current network not found
    2009/06/29 07:48:42 :: ifconfig eth0
    2009/06/29 07:48:42 :: ifconfig wlan0
    2009/06/29 07:48:42 :: iwconfig wlan0
    2009/06/29 07:48:42 :: GetCurrentNetworkID: Returning -1, current network not found
    2009/06/29 07:48:47 :: ifconfig eth0
    2009/06/29 07:48:47 :: ifconfig wlan0
    2009/06/29 07:48:47 :: iwconfig wlan0
    This repeats about 20 times.
    3) I connect to a network with hidden SSID. Every now and then when wicd finds the network on it's own it displays the SSID as \x00\x00\x00\x00\x00\x00\x00\x00\x00. When I click connect it won't connect saying incorrect password. I have to manually go "find hidden network" and then enter the ssid and then connect. Once it's connected I see both SSIDs, the one I just entered (it displays the hidden ssid correctly) and the previous one with the strange \x00\ stuff - both showing as connected (naturally as they are both the same network really). Is this normal behaviour?
    Why display both once connected when it's the same network?

    Any help appreciated.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Calling wicd users - need help with problem

    Hi,
    to solveproblem #1&2, you have to start the wicd service at boot time,

    Code:
    chkconfig wicd on
    HTH
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  3. #3
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Calling wicd users - need help with problem

    Thanks for your reply. As far as I was aware the service does start at boot time because I don't start it manually (i.e. after I've logged into the desktop wicd tries to log onto my network without me running it manually except for the wicd-client). Where can I check if it's being started at boot?

    What does the code do? I ran it in a terminal and got not feedback so not sure what it did.

    To start wicd service at boot do I just put wicd in the boot.local file?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Calling wicd users - need help with problem

    Start Yast - System - Runlevel editor. Here you can set wicd to start at boottime. Most common in expert mode to start wicd are runlevels 2, 3 and 5
    That's the way to do it.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Calling wicd users - need help with problem

    Thanks. Do you know what that chkconfig wicd ok does?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  6. #6
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Calling wicd users - need help with problem

    you can use chkconfig to enable or disable system services through CLI,
    but you need to do it with root user,

    Code:
    su
    chkconfig wicd on
    "chkconfig wicd on" will configure the wicd service to be started on next boot time

    you can read the man page for more details

    HTH
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  7. #7
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Calling wicd users - need help with problem

    OK. I'll haven't rebooted yet. I'll see how goes after I reboot.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  8. #8
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Calling wicd users - need help with problem

    Ok, it's been a couple of months since I brought this up, but I still haven't managed to resolve this satisfactorily. For some reason I just cannot get the wicd service to start properly. I've tried Knurpht's way
    Start Yast - System - Runlevel editor. Here you can set wicd to start at boottime. Most common in expert mode to start wicd are runlevels 2, 3 and 5
    That's the way to do it.
    but I get an error back saying
    /etc/init.d/wicd start returned 7 (program is not running):
    Any idea why YAST cannot start the wicd service? I'm running wicd 1.6.1 installed from this repo
    Code:
    http://download.opensuse.org/repositories/system:/wicd/openSUSE_11.1/
    I've tried doing an unconditional update on wicd but it didn't help. I'd appreciate any help from other wicd users here.
    Last edited by suse_tpx60s; 17-Sep-2009 at 04:14. Reason: Tidy up quote
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  9. #9
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Calling wicd users - need help with problem

    Quote Originally Posted by suse_tpx60s View Post
    I've tried Knurpht's way but I get an error back saying
    /etc/init.d/wicd start returned 7 (program is not running):
    To solve this you have to start Yast, go to System Services and select the ADVANCED (or EXPERT, I don't remember) mode.
    Then select the wicd service and check runlevels 2, 3 and 5.
    You probably tried starting the service in simplified mode, because I had the same error message.

    Using the advanced gui it works, although in my case it messed up something at boot. In fact boot started saying "failed" at the start of DHCP4 client, and (bigger problem) it freezes a few lines later, at the "Starting NFS client services: sm-notify idmapd" step.
    It stays there three or four minutes, then boot resumes. I can't understand why this happens.

  10. #10
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Calling wicd users - need help with problem

    Quote Originally Posted by Sciamano View Post
    To solve this you have to start Yast, go to System Services and select the ADVANCED (or EXPERT, I don't remember) mode.
    Then select the wicd service and check runlevels 2, 3 and 5.
    You probably tried starting the service in simplified mode, because I had the same error message.
    .
    I tried starting it in expert mode but I still get the same error message saying
    /etc/init.d/wicd start returned 7 (program is not running):
    Don't know why this happens. Wicd has always been a little tempramental on my system. Sometimes it will refuse to start after booting, then ask for root password and say something about the daemon failing to start. It then seems to put some rubbish in the wired config file which I need to firs remove before wicd client will start.

    I'm going to be switching to 11.2 during Xmas so not that bothered.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •