No doubt I've managed to hose some libraries, but for the life of me, I can't figure it out.

I'm running 11.1 with KDE 3.5 (I loathe the KDE 4 that shipped with 11.1 -- well discussed elsewhere, no need to get into that again here.) A few weeks ago, I decided to install KDevelop to write some gadgets for work.

Not only did KDevelop not work (a problem with libtools, apparently, best I could determine from a Web search), the process automatically installed KDE 4 without my consent. I then deleted KDevelop (since it wouldn't work) and set my system to default to KDE 3.5, which is what I want.

Since then, the sound doesn't work when playing Flash in Firefox, but I can live with that. What's more bothersome is that online updates seem to have disappeared. There was no icon in the tray.

I did a few Web searches and added back the kde4-kupdateapplet-zypp and the kde4 base libraries. The tray icon reappeared, but now every time I restart, I get a message box that says, "unable to find a backend applet."

A search here in the forum shows that this has happened to some others, and normally, reinstalling the zypp stuff should fix it. It didn't work for me. When I right-click on the Updater tray icon and select "configure applet," the drop-down for "backend" is blank. There are no choices.

I've also tried removing the update sources, then adding them back. I've tried "configure online update" from scratch. No luck.

When I run zypper list-updates at a root command prompt, it says, "no updates available," which doesn't sound right. My laptop, which also runs 11.1 with KDE 3.5 (same basic config) has installed several updates in the past couple of weeks.

Any ideas? I have no doubt that I've hosed a library that the updater wants, but I don't know which one.