Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to activate compiz ( at startup ),Opensuse 11.1, KDE 3.5

  1. #1

    Default How to activate compiz ( at startup ),Opensuse 11.1, KDE 3.5

    Hello! I installed Opensuse 11.1 with KDE 3.5 to my netbook. I am trying to use compiz, but I don't know how..I browsed through yast and found out that it is installed. I tried to install Compiz-config settings manager but still cannot see the effects by compiz. How can it be activated at startup. Please help

  2. #2

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    for what I know compiz works only with KDE 4.0 or higher
    Saluti
    R

  3. #3
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    In KDE4 you need to enable window effects from within desktop configuration. Can't say for KDE3.5 as I have never used it. As roberto says, it may not even be available for KDE3.5.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  4. #4
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    Hi,
    to activate compiz in KDE 3.5 go to
    Personal Settings (Configure Desktop)>KDE Components>Session Manager
    And choose compiz as your Window Manager,

    HTH
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  5. #5

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    Quote Originally Posted by maill View Post
    Hi,
    to activate compiz in KDE 3.5 go to
    Personal Settings (Configure Desktop)>KDE Components>Session Manager
    And choose compiz as your Window Manager,

    HTH
    I tried to change window manager to compiz but still no animations.
    I also tried suggestions like editing xorg.conf for AIGLx
    but still no luck. Please help

  6. #6
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    pls run compiz-manager
    or
    fusion-icon

    right click on the compiz icon at the system tray,
    select window manager option > compiz,

    if it is still not working, try the reload window manager option
    and for the animation settings, you can set them at the settings manager
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  7. #7

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    Quote Originally Posted by maill View Post
    pls run compiz-manager
    or
    fusion-icon

    right click on the compiz icon at the system tray,
    select window manager option > compiz,

    if it is still not working, try the reload window manager option
    and for the animation settings, you can set them at the settings manager
    I tried to run in terminal but some errors came up:

    erwin@linux-o0l3:~/Desktop> compiz-manager
    which: no fusion-icon in (/opt/kde3/bin:/home/erwin/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    Checking for Xdmx: not present.
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 00:02.0 0300: 8086:27ae (rev 03) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1024x576) to maximum 3D texture size (2048): Passed.
    Checking for nVidia: not present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    /usr/bin/compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
    /usr/bin/compiz (core) - Fatal: No manageable screens found on display

    do i need to install compiz-fusion? I only see "compiz-fusion-plugins-main" in yast, and it is installed...what other components am i missing at?

    Thanks for your patience

  8. #8
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    erwin@linux-o0l3:~/Desktop> compiz-manager
    which: no fusion-icon
    Please install fusion-icon package with yast or zypper,
    it's a python script to manage compiz,
    And then try to run it from terminal

    I got compiz working in my KDE 3.5,
    here's the list of my compiz packages, you could compare them with yours,
    and install the missing ones,

    Code:
    rpm -qa | grep -e compiz -e fusion
    
    python-compizconfig
    libcompizconfig
    compiz
    compizconfig-settings-manager
    compiz-kde
    fusion-icon
    libcompizconfig-backend-kconfig
    compiz-manager
    compiz-fusion-plugins-extra
    compiz-fusion-plugins-main
    HTH
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

  9. #9

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    Quote Originally Posted by maill View Post
    Please install fusion-icon package with yast or zypper,
    it's a python script to manage compiz,
    And then try to run it from terminal

    I got compiz working in my KDE 3.5,
    here's the list of my compiz packages, you could compare them with yours,
    and install the missing ones,

    Code:
    rpm -qa | grep -e compiz -e fusion
    
    python-compizconfig
    libcompizconfig
    compiz
    compizconfig-settings-manager
    compiz-kde
    fusion-icon
    libcompizconfig-backend-kconfig
    compiz-manager
    compiz-fusion-plugins-extra
    compiz-fusion-plugins-main
    HTH
    I got fusion-icon installed and some components, tried running compiz-manager and got the icon on the panel..However, still does not work. When I change window manager or reset it, my windows messes up and had to restart...got some more ideas?
    Thanks again for your patience..

  10. #10
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: How to activate compiz ( at startup ),Opensuse 11.1, KDE

    Hi,
    pls run this from the terminal:

    simple-ccsm

    and check the enable effects,
    if the problem persists pls read this page,

    Compiz Troubleshooting - openSUSE

    Goodluck
    "And just as you want men to do to you, you also do to them likewise."
    Luke 6:31 NKJV

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •