Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Auto update failure openSUSE10.3

  1. #1

    Default Auto update failure openSUSE10.3

    Hi, for various reasons, my "work-horse" distro is still openSUSE10.3. Auto update fails with the message:

    [QUOTE]
    4 Problems: Problem: No valid solution found with just resolvables of best architecture. Problem: kdelibs4-core cannot be installed due to missing dependencies Problem: Can't satisfy requirement libphononexperimental.so.4()(64bit) for kdelibs4-3.93.0.svn712047-6.2.x86_64[openSUSE-10.3-Updates] Problem: Can't satisfy requirement libphonon.so.4()(64bit) for libkde4-4.1.3-69.6.x86_64[Education] Problem: No valid solution found with just resolvables of best architecture. With this run only resolvables with the best architecture have been regarded. Regarding all possible resolvables takes time, but can come to a valid result. Solution 1: Make a solver run with ALL possibilities. Regarding all resolvables with a compatible architecture.
    [\QUOTE]

    How can I make the "solver run with ALL possibilities"?

    I confess that Yast's occasional failure to resolve the dependencies were and still remain a dark mystery to me. When Yast comes up with such message my "solution" has been to choose not to proceed with the installation...

    It would be great to resolve this problem. Any and all information will be greatly appreciated.

    OldAl.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Auto update failure openSUSE10.3

    Open a terminal and do:

    Code:
    zypper lr --details
    Post result
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Post Re: Auto update failure openSUSE10.3

    Thanks for your reply, caf4926. I followed your suggestion. My box is named amd64. Here is a conversation, using the suggested command.
    Code:
    ak@amd64:~> zypper lr --details
    Unknown option --details
    ak@amd64:~>
    ak@amd64:~> sudo zypper lr --details
    root's password:
    Unknown option --details
    ak@amd64:~>
    Not a big advance... Perhaps there is another zypper command? Can you suggest a good information source of explanation of zypper, perhaps better than the "man" pages? I guess that lr is "load repository", does that sound a reasonable supposition?

    I need to catch up with the zypper - openSUSE is moving along at a lively pace. Thanks for your help!

    OldAl.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,200
    Blog Entries
    1

    Default Re: Auto update failure openSUSE10.3

    The problem is zypper has undergone significant development since suse 10.3 version. (Most of us are now using openSUSE 11.X). He wanted you to provide list of configured repos. Instead, try

    zypper sl
    This suse 10.2 zypper reference may be useful.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Auto update failure openSUSE10.3

    zypper lr

    should do
    Zypper/Usage/10.3 - openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Auto update failure openSUSE10.3

    Quote Originally Posted by caf4926 View Post
    zypper lr

    should do
    Zypper/Usage/10.3 - openSUSE
    Thanks for the information. There is a lot of it in the reference... I better study it first, before bothering you again. As you must have realised,

    zypper lr

    listed the installed repositories.

    zypper update

    produced, not surprisingly, the same error as the attempted update from KDE GUI.

    Missing dependencies are a pain and well beyond my knowledge of Linux.

    Thank you all for responding - much appreciated.
    OldAl,
    http://akabaila.pcug.org.au/StructuralAnalysis.pdf

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,200
    Blog Entries
    1

    Default Re: Auto update failure openSUSE10.3

    Thanks for the information. There is a lot of it in the reference... I better study it first, before bothering you again. As you must have realised,

    zypper lr

    listed the installed repositories.
    Yes, but caf wanted you to post the repo list so they could be checked. Dependency issues could arise if required repos are not present and enabled for example.

  8. #8

    Default Re: Auto update failure openSUSE10.3

    Quote Originally Posted by deano_ferrari View Post
    Yes, but caf wanted you to post the repo list so they could be checked. Dependency issues could arise if required repos are not present and enabled for example.
    Here is the dialog with the list of repositories (they have been updated):

    Code:
    amd64:/home/ak # zypper lr
    #  | Enabled | Refresh | Type   | Alias
                            | Name
    ---+---------+---------+--------+-------------------------------------------------------------
    ------------------------+----------------------------------------------------
    1  | Yes     | No      | rpm-md | http://www2.ati.com/suse/10.3
                            | ATI Repository
    2  | Yes     | No      | rpm-md | http://ftp.skynet.be/pub/packman/suse/10.3/
                            | Packman Repository
    3  | Yes     | Yes     | rpm-md | openSUSE-10.3-Updates
                            | openSUSE-10.3-Updates
    4  | Yes     | No      | NONE   | Education
                            | Education
    5  | Yes     | No      | yast2  | http://download.opensuse.org/repositories/openSUSE:10.3/stan
    dard/                   | Main Repository (OSS)
    6  | Yes     | Yes     | rpm-md | X11:Drivers:Video
                            | X11:Drivers:Video
    7  | Yes     | No      | NONE   | NVIDIA Repository                                                                                                | NVIDIA Repository
    8  | Yes     | No      | rpm-md | http://download.opensuse.org/repositories/Virtualization:/Vi                             rtualBox/openSUSE_10.3/ | openSUSE BuildService - Virtualization (VirtualBox)
    9  | Yes     | Yes     | yast2  | openSUSE:10.3                                                                                                    | openSUSE:10.3
    10 | Yes     | Yes     | rpm-md | KDE:KDE3                                                                                                         | KDE:KDE3
    11 | Yes     | No      | rpm-md | http://download.opensuse.org/repositories/Virtualization:/Qe                             mu/openSUSE_10.3/       | openSUSE BuildService - Virtualization (QEMU)
    12 | Yes     | Yes     | rpm-md | home:rbos                                                                                                        | home:rbos
    13 | Yes     | No      | rpm-md | http://download.nvidia.com/opensuse/10.3                                                                         | NVIDIA Repository
    14 | Yes     | No      | yast2  | openSUSE10.3_repository_on_this_hdd.                                                                             | openSUSE10.3 repository on this hdd.
    15 | Yes     | No      | rpm-md | openSUSE:10.3:Update                                                                                             | openSUSE:10.3:Update
    16 | Yes     | No      | rpm-md | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_                             10.3/                   | openSUSE BuildService - X11:XGL
    17 | Yes     | No      | rpm-md | Main Update Repository                                                                                           | Main Update Repository
    18 | Yes     | No      | yast2  | http://download.opensuse.org/distribution/10.3/repo/non-oss/                                                     | Main Repository (NON-OSS)
    19 | Yes     | No      | NONE   | openSUSE:10.3:NonFree                                                                                            | openSUSE:10.3:NonFree
    amd64:/home/ak #
    It would be very useful to find out what is going on, so if the list tells you what the problem may be, I would very much appreciate hearing it. Thank you for your response and explanation of what I was requested (by caf) to do.
    OldAl,
    http://akabaila.pcug.org.au/StructuralAnalysis.pdf

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Auto update failure openSUSE10.3

    You seem to have some duplicates and repos disabled that I would enable.
    Are you using ATI or Nvidia?

    Do you know what you are using from education repo?
    You should enable Packman.

    Ideally, you should just have:
    Updates
    Oss
    Non-Oss
    Packman
    either ATI or Nvidia
    And KDE3 if you are using kde3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Auto update failure openSUSE10.3

    Quote Originally Posted by caf4926 View Post
    You seem to have some duplicates and repos disabled that I would enable.
    Are you using ATI or Nvidia?

    Do you know what you are using from education repo?
    You should enable Packman.

    Ideally, you should just have:
    Updates
    Oss
    Non-Oss
    Packman
    either ATI or Nvidia
    And KDE3 if you are using kde3
    I will disable all the other repositories and leave the above and see what happens with the update. I would like to get it going. Will not do it tonight, however, it is a bit late down under and I had a big day. We celebrated our 61-st (!) wedding anniversary yesterday, so I have to respond to my boss calling me to go to bed - it is 2200 hrs here...

    Thank you very much for your patient help! I will post the results, of course.

    Oh, my box has amd64 dual core processor, mobo has Nvidia chipsets (argh...) and there is an El Cheapo ATI graphics card, an Asus radeon EAH3450, so I will add an ATI repo, hopefully.
    OldAl,
    http://akabaila.pcug.org.au/StructuralAnalysis.pdf

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •