Results 1 to 8 of 8

Thread: Write to file on Win XP partition

  1. #1

    Default Write to file on Win XP partition

    Can anyone tell me how I can write to a file on my Windows XP partition. It is an NTFS partition. I am, for example, using Open
    Office and I open a file that I had made in MS Office, and make some changes. Then I want to save the changes. I am able to read, but I can't write.

    I can r-click the file in Dolphin, and select Properties, then select the Permissins tab, but I can't change the permissions.

    While I am on the subject, when I installed openSUSE, I got a username, but most of my windows files say they belong to the owner "root" and the group "users". Is "root" the main adminstrator? Do I log in to root by putting "root" for username? And how did "root" become a member of the "user" group. I don't recall being asked, during installation of the op sys, to make any groups.

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Write to file on Win XP partition

    You can change the permissions in Konsole.
    Open terminal and type su, and enter your root password.
    after that:
    chmod -R 777 /path/to/file/or/folder/
    777 can be changed to any, 775,664. Search for diff permissions type in google.

    Another thing you can do is, own the file:
    chown username /path/to/file/or/folder/
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  3. #3

    Default Re: Write to file on Win XP partition

    What does "recursively" mean in re to the chmod command? I had no trouble learning the number system. I just don't understand "recursively."

    I successfully changed the ownership of a folder to the user that I am currently logged in as. However if I open a file that is in that folder, it still opens as "read-only." Dolphin lists the "user" as having read and write permissions. What do they mean by "user"? Any user? The owner? If they mean any user, then what do you also need "group" and "anyone" for? Does "user" really mean "owner"?

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Write to file on Win XP partition

    Did u tried chmod?
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  5. #5

    Default Re: Write to file on Win XP partition

    I did chmod without the -R switch. I'm afraid to use it unless I first know what it does. After I did chmod 777 to the file, I looked at it in dolphin and its permissins did not change.

    What if I just log in as root instead of a lesser priveleged user?

    Also, if i do chmod to a folder, do subfolders, and and files in the folder, get changed?

    I did chmod --help - and got an answer which looked like totally gobble-de-gook to me.

  6. #6

    Default Re: Write to file on Win XP partition

    Yes, in dolphin, the main permissins screen lists owner, group, and others, while the advanced tab lists user, group, and others. Confusing.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Write to file on Win XP partition

    NTFS permissions and ownership are fixed by the command options used when the partition is mounted. Thereafter chmod and chown don't work in the ordinary Linux fashion. To change the permissions you must change the mount.

    More details can be found here:
    HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

    If you need further advice or have more questions, please ask (and also post the contents of the file system table located at /etc/fstab as a discussion point).
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Write to file on Win XP partition

    Hi. First of all: how is your ntfs partition mounted? Try to unmount it and then remount it using ntfs-3g as file system: login as root in a terminal then umount /your_ntfs
    mount -t ntfs-3g <your device> <your mount point>. Anyway ntfs-config could help you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •