Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Suse Newbie - Problems after installing NVidia Driver

  1. #1

    Default Suse Newbie - Problems after installing NVidia Driver

    Hi there,

    Switched from Fedora this week, and love the distro. I installed the Nvidia drivers after adding the directory to the Repo. All installed fine, but im having 2 issues which im hoping you more knowledgeable people can help with.....

    1) On login/logout, whenver it would change to a black screen for a second, im now getting random raw patterns on screen. These are red, or black and white, and sometimes you can see icons from the desktop underneath. They then go when it moves to the next screen.

    2) Some widgets arent displaying properly. The updater applet is overlaying, so the red triangle, the orange update icon and the green icon all overlay.

    I did a clean install and redid, following instructions from opensuse help and FAQ, but have the same problems.

    Can anyone assist me?

    Many many thanks.

  2. #2
    Join Date
    Jun 2009
    Location
    Fife
    Posts
    14

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    As far as I'm aware the random raw patterns glitch just seems to happen, less crippling and more a minor niggling, but Im not 100%sure on the 2nd point, you got a screenshot so we can better see?

    Also, did you compile the nvidia drivers or install them from the repository via 1click?
    GET TO THE CHOPPA!!!

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    Quote Originally Posted by leecheroflife View Post
    As far as I'm aware the random raw patterns glitch just seems to happen, less crippling and more a minor niggling.
    Yes, true. Its a minor glitch of screen after login and b4 just for a second. Not sure, what cause them. May be of video card. I am using Intel.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4
    Join Date
    Jun 2009
    Location
    Fife
    Posts
    14

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    Yeah that does seem to be the case, im running an NVIDIA 8400 using the most recent drivers (Compiled myself) and I get that glitch and yeah, it is really minor
    GET TO THE CHOPPA!!!

  5. #5

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    If i'm not wrong then if You change the login theme from within YaST then it won't happen anymore.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  6. #6
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    Quote Originally Posted by BenderBendingRodriguez View Post
    If i'm not wrong then if You change the login theme from within YaST then it won't happen anymore.
    Is it YaST OR configure desktop->Appearance->Splash Screen?
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  7. #7
    Join Date
    Jun 2009
    Location
    Fife
    Posts
    14

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    I've done that before and it still did it, i'll check again though, its one of those glitches that doesnt bother me to much though, its so minimal. lol
    GET TO THE CHOPPA!!!

  8. #8

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    There as a BUG in KDE bug tracking system (or NOVELL's) don't remember now that the kde system settings tool doesn't set most things related to login etc.

    So YaST is the way to go.

    P.S. It's not the splash screen's fault, it's the login manager, i remember a guy saying something that the openSUSE's login theme didn't have a string where other theme's had it by default and that adding that line to the login theme solved the problem for him. But i don't care since i don't use the default theme, too greenish
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  9. #9
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    Ok.
    I changed it from YaST->system->/etc/sysconfig Editor->Desktop->Display manager->DISPLAYMANAGER_KDM_THEME.
    I changed the value from SUSE to oxygen.
    oxygen theme is already there in:
    /usr/share/kde4/apps/kdm/themes

    But nothing changed after restarting PC. All the old theme with a glitch.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  10. #10

    Default Re: Suse Newbie - Problems after installing NVidia Driver

    Try changing the branding.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •