Results 1 to 5 of 5

Thread: VNC problems

  1. #1
    Join Date
    Apr 2009
    Posts
    27

    Question VNC problems

    I am trying to get TightVNC viewer running on a Windows machine to work with the VNC Server on my Linux Server. I can do the reverse quite easily and it works great. Yet when I connect to my Linux Server, I do not get what I expect.

    All I get is a blank grey screen with a cursor X on it, but no desktop, icons, or anything.

    The viewer lists it as:

    nobody's x11 desktop (servername:6);

    I set it up through yast and opened the firewall, but the yast setup does not give a lot of information about what is being setup or what screen it is setting up. I am assuming that it is screen 1 since that is the only one that connects though I don't understand what the 6 is after the servername.

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: VNC problems

    Hi Z_K

    Can you answer a few questions please:
    1. What version of Suse are you using?
    2. Which Desktop -- KDE3, KDE4, Gnome or whatever?
    3. There are several places in Yast for remote desktops server settings, exactly which one did you choose?
    4. Please post here the contents of the file xstartup which is located at /.vnc/xstartup (.vnc is a hidden directory).
    5. There are several options for VNC in the firewall settings -- please describe exactly which one/s you chose
    6. Please post the response you get from this console command:
      Code:
      rpm -qa | grep vnc
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Apr 2009
    Posts
    27

    Default Re: VNC problems

    1. What version of Suse are you using? 11.1
    2. Which Desktop -- KDE3, KDE4, Gnome or whatever? Gnome
    3. There are several places in Yast for remote desktops server settings, exactly which one did you choose?

    Really, I only know of two. What are the others? I used Remote Administration(VNC) to enable VNC and open the firewall. I also used Network Services (xinetd) to enable a different screen, but that did not work either.


    4. Please post here the contents of the file xstartup which is located at /.vnc/xstartup (.vnc is a hidden directory).

    I did not have one, I had to make one and I put in a file that I called xstartup :
    #!/bin/sh
    exec startx


    5. There are several options for VNC in the firewall settings -- please describe exactly which one/s you chose

    I am not sure about this one, but all I did was under allowed services and I allowed VNC Server and mini-HTTP Server.

    6. Please post the response you get from this console command:
    rpm -qa | grep vnc.

    response:
    libgtk-vnc-1_0-0-0.3.7-5.3
    tightvnc-1.3.9-80.41
    x11vnc-0.9.4-1.21
    xorg-x11-Xvnc-7.4-17.4.1

    Oh, one other thing that noticed is that my WebMin stopped working right after I started using VNC. I don't know if that is related or not.

  4. #4
    Join Date
    Apr 2009
    Posts
    27

    Wink Re: VNC problems

    Thanks, but I finally got it to work. I noticed another VNC entry in the firewall that I did not see before. I allowed that and now it works.

    Thanks again.


  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: VNC problems

    The questions were designed to look at the possible problems, so that's great you checked in the firewall allowed services list again.

    So can you tell me for my own interest, which VNC is running, x11vnc or xorg-x11-Xvnc? You should be able to find out by running this command which asks the system what's running:
    Code:
    ps aux | grep vnc
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •