Results 1 to 4 of 4

Thread: VNC Blank Screen

  1. #1
    shtaffa NNTP User

    Default VNC Blank Screen

    I have recently installed openSUSE 11.0 on my desktop at work. When I try to VNC to the box, I get the gray checkered background and nothing more.

    Any help would be appreciated. I want to try to use Linux in the workplace as opposed to Windows but I must have the capability to access my computer remotely.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: VNC Blank Screen

    On Mon, 30 Jun 2008 13:06:03 GMT
    shtaffa <shtaffa@no-mx.forums.opensuse.org> wrote:

    >
    > I have recently installed openSUSE 11.0 on my desktop at work. When I
    > try to VNC to the box, I get the gray checkered background and nothing
    > more.
    >
    > Any help would be appreciated. I want to try to use Linux in the
    > workplace as opposed to Windows but I must have the capability to
    > access my computer remotely.
    >
    > Thanks.
    >
    >

    Hi
    VNC doesn't know what desktop to start. Might I suggest FreeNX or NX
    from nomachine.com, it uses ssh for the connection.
    http://en.opensuse.org/FreeNX_Server_HOWTO

    Else have a look here;
    http://en.opensuse.org/VNC_HOWTO

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 19 days 10:02, 0 users, load average: 2.25, 2.11, 2.01
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  3. #3

    Default Re: VNC Blank Screen

    Malcolm schrieb:
    > On Mon, 30 Jun 2008 13:06:03 GMT
    > shtaffa <shtaffa@no-mx.forums.opensuse.org> wrote:
    >
    >> I have recently installed openSUSE 11.0 on my desktop at work. When I
    >> try to VNC to the box, I get the gray checkered background and nothing
    >> more.
    >>
    >> Any help would be appreciated. I want to try to use Linux in the
    >> workplace as opposed to Windows but I must have the capability to
    >> access my computer remotely.
    >>
    >> Thanks.
    >>
    >>

    > Hi
    > VNC doesn't know what desktop to start. Might I suggest FreeNX or NX


    It starts twm as default, see .vnc/xstartup

  4. #4

    Smile Re: VNC Blank Screen

    I experienced the same problem with a blank screen on VNC connections to an openSUSE 11.0 boks the night between Saturday and Sunday. After much trial and error, attempt to follow what others suggested etc. I found the solution on the RealVNC forum where Jerome R. Westrick jerry "at" westrick.com on Fri Sep 14 16:26:04 2007 in a message wrote:

    In Yast2 check the following setting:

    System->/etc/syconfig Editor
    Desktop->Display manager:
    DISPLAYMANAGER_REMOTE_ACCESS = YES

    I did that, and after a server restart (properly only needed an X restart, but at 2 AM no one really notice) I could connect to the openSUSE boks both locally, i.e. through localhost in a java-enable browser, and remotely from a windows XP boks using either a java-enable browser or the NoMachine client for Windows. Yes, I installed the FreeNX server on the openSUSE machine using the build-service and the one-click install.

    With best regards from Niels
    Last edited by Niels49; 22-Jun-2009 at 08:25. Reason: Spelling errors!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •