Results 1 to 5 of 5

Thread: Youtube does not work in openSUSE with Firefox

  1. #1

    Unhappy Youtube does not work in openSUSE with Firefox

    Following upgrade to openSUSE11.1 Youtube flash movies no longer work on my pc.

    I have read everything I can find on this forum and even on the Fedora forum and after 4 days of trying to get Youtube to work, the best I can get is to have the movies play as sound only with no video.

    The main purpose of this computer is for my handicapped son to be able to use Youtube.

    Information in this thread... Flash, k3b, Amarok - Install Guide - openSUSE Forums... does not work

    If it is no longer possible to use openSUSE to watch Youtube can anyone recommend a distro which does work with Youtube. Or is it better to change to Microsoft Windows?

  2. #2

    Default Re: Youtube does not work in openSUSE with Firefox

    Finally, I found the answer on another thread... Flash player only works sporadicly. - openSUSE Forums.
    Originally Posted by Knurpht: Remove the flash-player through software installer and download the 64-bit Flashplayer. Extract the .so file in /usr/lib64/browser-plugins. That's it. Works great on all my 64-bit systems
    ...
    This hack really does appear to work. Odd thing is that I have openSUSE11.1(64bit) on another computer and that computer plays Youtube videos with out this hack

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Youtube does not work in openSUSE with Firefox

    Hard to say what went wrong with your system update. The flash player (32-bit) that uses nspluginwrapper as a 32-bit adaptation layer that are supplied by openSUSE work just fine. The 64-bit player from Adobe is said to work well but officially is still alpha. Anyway enjoy youtube.

  4. #4

    Default Re: Youtube does not work in openSUSE with Firefox

    ATTENTION!!!!!!!!!

    Flash does not work with Firefox because PulseAudio is running!!!!

    Kill PulseAudio and uninstall. They are incompatible.

    This is yet another preventable bug with 11.1.

    Could someone at openSUSE please tell me how to keep Kdeinit from trying to start PA? I cannot for the life of me figure out where it's getting started from! And, please fix this. This is absurd. Kdeinit keeps trying to start PA even when PA is uninstalled.

  5. #5

    Default Re: Youtube does not work in openSUSE with Firefox

    Okay. This should not have been so difficult to find.

    The way you disable PA from even trying to start is to remove the desktop file "pulseaudio.desktop" from /etc/xdg/autostart.

    This will make it possible to keep PA installed while keeping it from starting, and it eliminates that godawful kdeinit error message every time you log in.

    In order to not lose the file, I created a "do_not_start" folder in /etc/xdg/autostart, moved the pulseaudio.desktop file into it and set the permissions to deny all entry (must be done as root). I don't know that the autostart stuff will or won't read subfolders, I just didn't want to take the time to test it.

    There's something screwed up in yast where this file should be, but is not, deleted when PA is removed.

    This made flash player audio work on my machine and didn't screw up anything else.

    I wonder what PA is for.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •