Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Surf Anonymously: Tor, Privoxy, Firefox Problem

  1. #1

    Default Surf Anonymously: Tor, Privoxy, Firefox Problem

    I have problem running Privoxy. I installed it using Yast. In Firefox, I set the manual proxy configuration of http to 127.0.0.1 8118 and the SOCKS host to 127.0.0.1 9050.

    I copied all the files from /etc/privoxy to my home folder /home/xuser.

    I start privoxy by going to terminal and typing:

    Code:
    xuser@linux-w7mn:~> /usr/sbin/privoxy
    Jun 20 21:37:27.786 Privoxy(7fc4c89216f0) Info: Privoxy version 3.0.10
    Jun 20 21:37:27.786 Privoxy(7fc4c89216f0) Info: Program name: /usr/sbin/privoxy
    When I try to connect, I get this message:


    Proxy Server Refused Connection

    Firefox is configured to use a proxy server that is refusing connections.

    The browser is configured to use a proxy server, but the proxy refused a connection.

    * Is the browser's proxy configuration correct? Check the settings and try again.
    * Does the proxy service allow connections from this network?
    * Still having trouble? Consult your network administrator or Internet provider for assistance.
    I checked the man page. I checked their Privoxy - Home Page. I found nothing specific to Suse 11.1. I found nothing on Google for Suse 11.1 either.

    Any ideas how I can get this to work?

  2. #2

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    sounds like you have installed the things you need, check in yast2>System>System Services and make sure privoxyd and tor are enabled. Hopefully that will solve your problem. If not you will have to review the privoxy config file.

    Note: version of tor prior to 0.2.0.34 need to be updated for security reasons. Torbutton extension from Mozilla facilitates use of tor and automatically makes adjustments to java/javascript rules that can leave you open to revealing your IP (recommended). Consider installing Tork (KDE3) even if you are using KDE4, it can give you control of your tor exit and entry points. Both current tor and Tork rpms are in the Build Service.

  3. #3
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 04:06 to write:

    >
    > I have problem running Privoxy. I installed it using Yast. In Firefox,
    > I set the manual proxy configuration of http to 127.0.0.1 8118 and the
    > SOCKS host to 127.0.0.1 9050.
    >
    > I copied all the files from /etc/privoxy to my home folder
    > /home/xuser.


    Now I know nothing about privoxy but why did you have to copy them to your
    /home? and if so have they got the right perms to perform correctly?

    Just a random thought.


    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  4. #4

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Privoxy tor squid - openSUSE

    My old howto that someone kindly transposed is here. It also looks like someone has updated for it 11.0.

    Sorry I can't assist more but the benefits for me, where out weighed by the loss in speed.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  5. #5

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by j_xavier View Post
    sounds like you have installed the things you need, check in yast2>System>System Services and make sure privoxyd and tor are enabled. Hopefully that will solve your problem. If not you will have to review the privoxy config file.
    I checked yast/stystem/system services. Neither were enabled. I was only able to at first enable Tor. Privoxy was attempting to start, but exited with an error. So, I went to advanced and set Privoxy to run at Run Levels 3 and 5. I restarted after saving these settings. I opened System Services and Privoxy and Tor were both enabled, but with Asterisks near their names?

    I launched Firefox, double checked my proxy settings (http and socks set as mentioned above) and set Firefox to use proxy. I hit the Tor button to enable it.

    When I try to load a web page, I get Blank message in Firefox with the option to create an exception, I copied the link location:

    link labeled:

    Code:
    Or you can add an exception
    link:

    Code:
    javascript:showSecuritySection();
    The button reads: Try Again?

    Any link I try brings this message.

  6. #6

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by baskitcaise View Post
    Now I know nothing about privoxy but why did you have to copy them to your
    /home? and if so have they got the right perms to perform correctly?

    Just a random thought.
    An older forum here suggested to do it. I believe I Privoxy wouldn't launch from terminal until I copied those files.

  7. #7

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by FeatherMonkey View Post
    Privoxy tor squid - openSUSE

    My old howto that someone kindly transposed is here. It also looks like someone has updated for it 11.0.
    The Privoxy Installtion how-to reads:

    Firstly we setup Privoxy. Using Yast -> Software -> Software Management Search for Privoxy and install. (You need a Yast installation source OSS repo)
    Done that fine.

    Check if the privoxy is executing:

    * Restart your computer and log in as the root user
    * Open a terminal window and execute: ps -ef | grep privoxy
    * You should get a listing with two lines:
    o The privoxy process
    o The "grep privoxy" process
    * If you only get "grep privoxy", then the proxy is not started!
    Did this, Privoxy is not running.

    Now, I go to the last part of the Privoxy how-to.

    In my Opensuse 11.0 installation, I had to add the privoxy to the "init" startup. Script "/etc/init.d/privoxy" was installed, but no links were set in the "rc?.d" directories to the script.
    How do I know if Privoxy needs to be added to "init" startup? If it does, how do I do that?

    How do I know if script "/etc/init.d/privoxy" is installed? How do I do this if it is not?

    How do I check to see if links are set to rc.d directories? If they are not set, how do I do that?

    If I can get all my questions answered, get Tor and Privoxy up and running with Firefox, I will write out a non-assuming how-to from start to finish.

  8. #8

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    If you found a rpm it is highly likely you'll be able to enable via the runlevel editor. Otherwise as suggested you need an init startup script.

    My original had a very hackish solution, but I doubt you need that option. But if you do then you should find some doc/skel in init.d sorry that is as much as I can help now. That originally was from around about 10.1 iirc.

    wiki http://en.opensuse.org/SDB:How_to_Cr...wn_Init_Script
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  9. #9

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    FeatherMonkey

    Tor and Privoxy seemd to be enabled by System Services, although they do have asterisks next to the word Yes* (for being enabled).

    I'm not sure, but does not System Services write the init scripts for me?

    If so, there must be a problem somewhere else, not init scripts. Firefox is not allowing me to bring up web pages.

  10. #10

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    i did not have to copy any privoxy files to my home directory to make it work. the files it needs to create there will be written when it runs.

    the asterisk in yast2 indicates that the service will be started when it is called instead of being loaded all the time and can be changed depending on your needs.

    yast2 will make the appropriate init changes depending on your settings, no manual edit is necessary.

    your Firefox error message is not really clear to me. it sounds like privoxy is not running...or it is running and passing the connection to tor but is not recieving the SSL certificate verification which prevents Firefox from rendering the webpage(by default Firefox will not render a SSL page unless it verifies the cert, it displays error and presents the opportunity to make an exception).

    just to check, review the privoxy config file /var/lib/privoxy/etc/config for the two pertinent uncommented lines that need to exist:

    listen-address 127.0.0.1:8118
    forward-socks4a / 127.0.0.1:9050 .

    the other thing that comes to mind is that your openssl libraries may not be up to date. Type openssl in the Search bar in Yast2 and see if there are updates available.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •