Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Surf Anonymously: Tor, Privoxy, Firefox Problem

  1. #11

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by j_xavier View Post
    i did not have to copy any privoxy files to my home directory to make it work. the files it needs to create there will be written when it runs.
    Ok, I removed those files. Then, I went to Terminal and typed /etc/sbin/privoxy to try to launch Privoxy. It says no such file. Before, it appeared to launch Privoxy. Without those files there, what command can I use?

    I verified this in the config file. Even the period at the end is there.

    listen-address 127.0.0.1:8118
    forward-socks4a / 127.0.0.1:9050 .
    Quote Originally Posted by j_xavier View Post
    the other thing that comes to mind is that your openssl libraries may not be up to date. Type openssl in the Search bar in Yast2 and see if there are updates available.
    I assume you mean Online Updates in Yast? There was one file that showed up under Security Updates. I did the update. I'm restarting now.

  2. #12

    Default Privoxy still not working.

    Privoxy doesn't seem to run:

    Code:
    xuser@linux-w7mn:/etc/privoxy> privoxy
    
    Program 'privoxy' is present in package 'privoxy', which is installed on your system.
    
    Absolute path to 'privoxy' is '/usr/sbin/privoxy', so it might be intended to be run only by user with superuser privileges (eg. root).
    
    bash: privoxy: command not found

    I copied the files to my home folder:

    Code:
    xuser@linux-w7mn:/etc/privoxy> sudo cp *.* /home/xuser
    I tried to start Privoxy:

    Code:
    xuser@linux-w7mn:~> /usr/sbin/privoxy
    Jun 21 11:54:18.181 Privoxy(7f87015866f0) Info: Privoxy version 3.0.10
    Jun 21 11:54:18.182 Privoxy(7f87015866f0) Info: Program name: /usr/sbin/privoxy
    Jun 21 11:54:18.182 Privoxy(7f87015866f0) Fatal error: can't check configuration file '/home/xuser/config':  No such file or directory
    For some reason, cp did not copy the config file, so I copied it directly by name:

    Code:
    xuser@linux-w7mn:/etc/privoxy> cp config /home/xuser
    Now, now I try to launch Privoxy again:

    Code:
    xuser@linux-w7mn:~> /usr/sbin/privoxy
    Jun 21 12:04:53.377 Privoxy(7f8c9868c6f0) Info: Privoxy version 3.0.10
    Jun 21 12:04:53.377 Privoxy(7f8c9868c6f0) Info: Program name: /usr/sbin/privoxy
    I test to see if it's working using ps:

    Code:
    xuser@linux-w7mn:~> sudo ps -ef|grep privoxy
    root's password:
    xuser    10784  5192  0 12:09 pts/1    00:00:00 grep privoxy
    Again, it is not working.

    Any ideas how to get it working?

  3. #13
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 15:16 to write:

    >
    > baskitcaise;2002375 Wrote:
    >> Now I know nothing about privoxy but why did you have to copy them to
    >> your
    >> /home? and if so have they got the right perms to perform correctly?
    >>
    >> Just a random thought.

    >
    > An older forum here suggested to do it. I believe I Privoxy wouldn't
    > launch from terminal until I copied those files.
    >
    >


    Another off the wall thought here,

    Is pivoxy supposed to be executed as user?

    Looking at one of your other posts it suggests that it is root only.

    Try opening a root session in a terminal and launching from there

    Note: not a sudo session but a full blown root by opening a console and
    using

    su
    (enter root password)

    and then try launching.

    sudo only works for the first command and then you drop back to user privs.

    su

    give full control until you either type

    exit or close the term session.

    HTH

    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  4. #14

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by baskitcaise View Post
    Is pivoxy supposed to be executed as user?
    The official Privoxy site say not to run it as root.

  5. #15
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    suseuser100 adjusted his/her AFDB on Sunday 21 Jun 2009 19:06 to write:

    >
    > baskitcaise;2002508 Wrote:
    >>
    >> Is pivoxy supposed to be executed as user?
    >>

    >
    > The official Privoxy site say not to run it as root.
    >
    >


    Ah OK, disregard me then

    ;-)

    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  6. #16

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    baskitcaise is correct.

    You're reading stuff you don't need to concern your self with you have to start the service via runlevels or manually with su /etc/init.d/privoxy start.

    if you got an rpm it is highly likely that it is configured correctly. The statement is the same as not running a web server as root(Try starting httpd as user without su), you have a dedicated user iirc it will be privoxy.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  7. #17
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    FeatherMonkey adjusted his/her AFDB on Sunday 21 Jun 2009 21:16 to write:

    >
    > baskitcaise is correct.
    >
    > You're reading stuff you don't need to concern your self with you have
    > to start the service via runlevels or manually with su
    > /etc/init.d/privoxy start.
    >
    > if you got an rpm it is highly likely that it is configured correctly.
    > The statement is the same as not running a web server as root(Try
    > starting httpd as user without su), you have a dedicated user iirc it
    > will be privoxy.
    >
    >


    Ah, I thought these old grey cells where not deceiving me.

    It was the fact that he copied the configs from /etc that puzzled me because
    unless he changed perms then it was almost certain they would not run as
    user.

    Also in one of the posts the error message said to run with su or root.

    I may not always be right and an old f^rt with it but sometimes the law of
    averages do step into my favour ( not very often though )

    :-)

    --
    Mark
    Cavet emptor
    Nullus in verba
    Nil illegitimi carborundum

  8. #18

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    Quote Originally Posted by FeatherMonkey View Post
    baskitcaise is correct.

    You're reading stuff you don't need to concern your self with you have to start the service via runlevels or manually with su /etc/init.d/privoxy start.

    if you got an rpm it is highly likely that it is configured correctly. The statement is the same as not running a web server as root(Try starting httpd as user without su), you have a dedicated user iirc it will be privoxy.
    I tried to just run it without any of the fancy terminal stuff. I downloaded them using Yast. I set the Firefox settings. Didn't work.

    Sure could use a comment from someone that has it working, or is guru enough to help me finish getting this from install to up and running.

  9. #19

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    j_xavier told you what to do here openSUSE Forums - View Single Post - Surf Anonymously: Tor, Privoxy, Firefox Problem

    It is no more complicated than that. Install privoxy check that works install tor check that works. Just have 1 line to edit in config, and have to tell your browser to use 127.0.0.1 8118.

    Now you can either start them once of with rctor start and rcprivoxy start. Then just go to system runlevels to be fair much about the tut is outdated and so easy now, compared to when I did that howto.

    If you're asking how do I enable it to start automatically via runlevels then ask... you need expert and choose your default runlevel normally 5.

    You don't need to be an expert, just need to work through it methodically.(I've just done this in about 4 mins including downloading.)

    Its still painfully slow as I remember so my suggestion is to add squid to the equation at least for non-dynamic pages it should help.

    Also be aware you might as well give up all your plugins many of them maybe leaking..
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  10. #20

    Default Re: Surf Anonymously: Tor, Privoxy, Firefox Problem

    recap: the rpms for privoxy (and tor) that i have used from repos or Build Service will start privoxy as root during startup provided that they are enabled in yast2>System>System Services. There is no reason to try to start them as user.

    as i mentioned before, the error page that Firefox gives you when you try to use it is not clear to me. since you only gave the link info, the entire error message is unknown, but it seemed to be the standard message that Firefox gives when an SSL connection cannot be verified... this happens often using tor because of latency... the cert server validation lags too far behind the delivery of the webpage and it times out. In addition, you did not mention that your Firefox connection settings included the No Proxy [localhost,127.0.0.1] entry.

    Locate and install the Torbutton extension on Mozilla's website. This will assure that your connection settings will be correct to use Tor with Firefox and provide the added benefit of disabling java/javascript (if you enable javascript you might as well not use tor, your real ip number can be retrieved with a simple script), cookies, etc.

    At this point i believe your tor/privoxy install is working correctly and the problem lies elsewhere.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •