Hi. I installed opensuse 11.1 on my computer few months ago, and using vesa driver straight after installation made the system look awful - the screen geometry and aspect ratio were completely broken, and system refused to set bigger resolutions. I used one-click install from here (for the appropriate model, of course):


ASAP. I have 8800 GTS 512MB card. After rebooting, I was greeted with command line interface saying there was a fatal error when trying to start X server - 'couldn't load module 'nvidia'' was the cause, AFAIR. I needed to boot to failsafe mode, when I searched for 'nvidia' in YaST. I found out, that I had x11-video-nvidiaG02 installed (seemed fine) and nvidia-gfx02-kmp-trace
Now, I am not a very big linux power user, but I think there are several kernel types, and trace isn't the one 'normal users' use. I deleted the trace one and chose to install nvidia-gfx02-kmp-default. System worked perfectly fine after that.
I ignored that fact, hoping somebody else would fix this instead of me - the NVIDIA site in opensuse and it one-click install will be something many users use, right? Well, it apparently seems not. I reinstalled my system today only to find it unfixed, I recalled what I did the previous time and it works fine as it did before.

So, will somebody fix it and make one-click install point to 'default' kernel version driver, instead of 'trace' ?Ia m sure not many newbies would be able to find out what to do in such situation, I solved this issue more than by luck than by knowledge, I must admit.

Thanks in advance!