Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

  1. #1
    David Gersic NNTP User

    Default OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    I resolved my (Intel) based lack of working desktop effects and other
    screwy video problems by installing an nVidia card. Now I have Gnome and
    desktop effects working fine with one exception: KMail.

    When KMail starts, it goes to the full screen, with no window
    decorations, and disables desktop effects.

    Any suggestions? (Comments on why I shouldn't want desktop effects will
    be ignored.) I'm not totally opposed to switching from KMail to Evolution
    if I have to. I got used to KMail with my old setup (SuSE 9.2/KDE), but I
    don't like the new version as much as the old one.


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    David Gersic adjusted his/her AFDB on Friday 19 Jun 2009 16:29 to write:

    > I resolved my (Intel) based lack of working desktop effects and other
    > screwy video problems by installing an nVidia card. Now I have Gnome and
    > desktop effects working fine with one exception: KMail.
    >
    > When KMail starts, it goes to the full screen, with no window
    > decorations, and disables desktop effects.
    >
    > Any suggestions? (Comments on why I shouldn't want desktop effects will
    > be ignored.) I'm not totally opposed to switching from KMail to Evolution
    > if I have to. I got used to KMail with my old setup (SuSE 9.2/KDE), but I
    > don't like the new version as much as the old one.
    >
    >



    IIRC there is a setting in the compiz control to fix the missing decorations
    for KDE apps, but I do not run gnome or compiz so I have no idea where it is
    :-)

    Just have a look about or else someone might jump in with the right place.

    HTH
    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  3. #3
    David Gersic NNTP User

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    On Fri, 19 Jun 2009 22:14:06 +0000, baskitcaise wrote:

    > IIRC there is a setting in the compiz control to fix the missing
    > decorations for KDE apps, but I do not run gnome or compiz so I have no
    > idea where it is


    Any idea what it might be called? I don't see anything in there that
    looks likely.


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    Hi, which version of compiz-fusion are you using?

    You can find out by opening a terminal and typing:

    Code:
    compiz --version
    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    David Gersic adjusted his/her AFDB on Saturday 20 Jun 2009 16:29 to write:

    > On Fri, 19 Jun 2009 22:14:06 +0000, baskitcaise wrote:
    >
    >> IIRC there is a setting in the compiz control to fix the missing
    >> decorations for KDE apps, but I do not run gnome or compiz so I have no
    >> idea where it is

    >
    > Any idea what it might be called? I don't see anything in there that
    > looks likely.
    >
    >


    I am not sure I don`t have compiz here, but IIRC there might be a section
    under Workrounds for QT?????

    Also it might be down the window decs you have set for the QT apps, the one
    time I did try compiz I think I had to set the decs to a theme tht was
    compat with it.

    But that was ages ago so might be completely out of date info


    I just did a google for compiz+qt+deorations+missing and got this:

    http://tinyurl.com/mklw2p

    Have a look at the archlinux result, might help but I cannot test as I don`t
    do Gnome or compiz.

    HTH
    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  6. #6
    David Gersic NNTP User

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    On Sat, 20 Jun 2009 16:16:02 +0000, ijbreakey wrote:

    > Hi, which version of compiz-fusion are you using?


    dgersic@linux:~> compiz --version
    compiz 0.7.8


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    Alright, try opening up CompizConfig Settings Manager (CCSM) and Under Utility, Workarounds should be checked. Then go into it and make sure Legacy Fullscreen Support is UNCHECKED. I think that should do the trick.

    Unless when you say the desktop effects are disabled, there's a message that pops up that says desktop effects have been disabled. This should work if that's not the case.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  8. #8
    David Gersic NNTP User

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    On Sun, 21 Jun 2009 15:56:01 +0000, ijbreakey wrote:

    > Alright, try opening up CompizConfig Settings Manager (CCSM) and Under
    > Utility, Workarounds should be checked. Then go into it and make sure
    > Legacy Fullscreen Support is UNCHECKED. I think that should do the
    > trick.


    Ah, ha. Thanks, that did the trick!


    > Unless when you say the desktop effects are disabled, there's a message
    > that pops up that says desktop effects have been disabled.


    No, no message pop up. Just going back in to SCCSM and finding the
    "enable" box unchecked.


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  9. #9
    David Gersic NNTP User

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    On Sun, 21 Jun 2009 15:56:01 +0000, ijbreakey wrote:

    > Alright, try opening up CompizConfig Settings Manager (CCSM) and Under
    > Utility, Workarounds should be checked. Then go into it and make sure
    > Legacy Fullscreen Support is UNCHECKED. I think that should do the
    > trick.


    I spoke too soon. It does half the trick. I can now start Kmail without
    desktop effects shutting down, but now when I exit Kmail, desktop effects
    dies again. Same as before, there's no warning or anything, just it's no
    longer enabled and going in to the SCCSM tool finds the "enable desktop
    effects" box unchecked.


    --
    ---------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Novell Knowledge Partner http://forums.novell.com

    Please post questions in the newsgroups. No support provided via email.


  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: OpenSuSE 11.1 Gnome and Desktop Effects vs. KMail

    Hmm.. whereas 0.7.8 should be working for you, you could always try upgrading to 0.8.2 since it does have some bugfixes.

    You can follow this threads advice for that (don't get rid of the fusion-icon as it still works with 0.8.2):

    Compiz hell ? Need help - openSUSE Forums

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •