Results 1 to 4 of 4

Thread: having issues running ./configure on ffmpeg 0.5

  1. #1

    Default having issues running ./configure on ffmpeg 0.5

    I extracted/compiled ffmpeg-0.5.tar.bz2 with the "sudo tar xvjf [package]" command in terminal and proceded to sudo ./configure the results but received this error:


    androjeans@T3RH4X0R:~/ffmpeg-0.5> sudo ./configure
    Unknown C compiler gcc
    gcc is unable to create an executable file.
    If gcc is a cross-compiler, use the --enable-cross-compile option.
    Only do this if you know what cross compiling means.
    C compiler test failed.
    If you think configure made a mistake, make sure you are using the latest
    version from SVN. If the latest version fails, report the problem to the
    ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
    Include the log file "config.err" produced by configure as this will help
    solving the problem.

    taking a stab at trying to use the --enable-cross-compile switch, this is the error I received:

    androjeans@T3RH4X0R:~/ffmpeg-0.5> sudo ./configure --enable-cross-compile
    Unknown C compiler gcc
    gcc is unable to create an executable file.
    C compiler test failed.
    If you think configure made a mistake, make sure you are using the latest version from SVN.
    If the latest version fails, report the problem to the
    ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
    Include the log file "config.err" produced by configure as this will help
    solving the problem.

    I'm new to linux, but I am NOT new to using computers OR programming.
    I looked around trying to figure out what I'm doing wrong, but to no avail. Any help will be appreciated.

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: having issues running ./configure on ffmpeg 0.5

    You don't have C compiler installed. Install gcc.
    Code:
    su
    zypper install gcc
    You might come across further package requirements like this. Do a search and install. In order to search for a pattern, do:
    Code:
    zypper search pattern
    Example:
    Code:
    zypper search cc
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: having issues running ./configure on ffmpeg 0.5

    thank you, sire.

    however, at the moment, I have much bigger fish to fry. (Though, I kind of figured that was the issue [the lack of gcc]). I made the mistake of trying to install a windows app that requires .NET framework and had to reinstall suse. Now my strictly data drive (which was in no way, shape or form related to my suse installation except that I had to back up and format with ext3 to replace the NTFS) seems to have no data on it. It seems like it just copied my /home/ folder to it and that's it. Very strange.

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: having issues running ./configure on ffmpeg 0.5

    I didn't fully understand your disk issue.

    You never have to reinstall openSUSE just because you tried to install an invalid package.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •