Results 1 to 5 of 5

Thread: Dependency issues with upgrade to KDE 4.2.4

  1. #1
    DerryFitz NNTP User

    Default Dependency issues with upgrade to KDE 4.2.4

    Hi,
    I'm having issues updating to KDE 4.2.4 on OpenSuse 11.1, any help would be appreciated,
    This is what Yast spits out:

    #### YaST2 conflicts list - generated 2009-06-16 10:37:13 ####

    kdepim4-4.2.1-99.4.i586 requires libkleopatraclientgui.so.0.2.1, but this requirement cannot be provided
    deleted providers: libkdepim4-4.2.1-99.4.i586[@System]
    [ ] do not install kde4-gwenview-4.1.3-4.7.i586

    [ ] Ignore some dependencies of kdepim4




    #### YaST2 conflicts list END ###

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,792
    Blog Entries
    14

    Default Re: Dependency issues with upgrade to KDE 4.2.4

    If you look at the version numbers, you see that the kde4-gwenview package is still 4.1.3
    Solution: choose to not install kde4-gwenview. It will probably come back with more: deinstall kde4-gwenview if asked for.After the installer has finished updating you can install the package gwenview (without the kde4 prefix)
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: Dependency issues with upgrade to KDE 4.2.4

    Originally the kde4 version of gwenview was called kde4-gwenview and the kde3 version was called gwenview. But they have recently changed it round so that the kde4 version of gwenview is now called gwenview and the kde3 version is called kde3-gwenview.

    So kde4-gwenview is now obsolete.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,792
    Blog Entries
    14

    Default Re: Dependency issues with upgrade to KDE 4.2.4

    Didn't want to "over-info". The same story goes for:
    Amarok
    k3b
    digikam
    List is by no means complete.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    DerryFitz NNTP User

    Default Re: Dependency issues with upgrade to KDE 4.2.4

    Thanks for the help, much appreciated, it worked like a charm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •