Results 1 to 9 of 9

Thread: KDE 4.1 to 4.2 in OpenSuse 11.1

  1. #1
    slackma NNTP User

    Default KDE 4.1 to 4.2 in OpenSuse 11.1

    Hi all!

    Ive read all themes related to my question, but i cant resolve issues.

    My system: OpenSuse 11.1, 4.1.3 (KDE 4.1.3) "release 4.10.4"

    Im using following instruction how-to link: KDE4.2.* (How To Add) Guide. - openSUSE Forums

    Also,
    Code:
    darkstar:/home/slackman # zypper lr --details
    #  | Alias                 | Name                  | Enabled | Refresh | Priority | Type   | URI                     | Service
    ---+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1  | KDE42                 | KDE42                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/                     |
    2  | KDE42Community        | KDE42Community        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/ |
    3  | Qt44                  | Qt44                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt44/openSUSE_11.1/                   |
    4  | devel:tools:building  | devel:tools:building  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/      |
    5  | openSUSE 11.1-0       | openSUSE 11.1-0       | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/sr0                     |
    6  | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1                     |
    7  | repo-debug            | openSUSE-11.1-Debug   | No      | Yes     |  100     | NONE   | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                     |
    8  | repo-non-oss          | openSUSE-11.1-Non-Oss | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                     |
    9  | repo-oss              | openSUSE-11.1-Oss     | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                     |
    10 | repo-source           | openSUSE-11.1-Source  | No      | Yes     |  100     | NONE   | http://download.opensuse.org/source/distribution/11.1/repo/oss/                     |
    11 | repo-update           | openSUSE-11.1-Update  | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1/                     |
    darkstar:/home/slackman #
    And when i try update unconditionally i receive a lot of warnings. This is saved list of my conflicts.

    Code:
    #### YaST2 conflicts list - generated 2009-06-13 15:10:34 ####
    
    kde4-kerry-0.2.90-7.15.i586 requires kdepimlibs4 >= 4.2.4, but this requirement cannot be provided
    uninstallable providers: kdepimlibs4-4.2.4-1.5.i586[KDE42]
        [ ] Following actions will be done:
    do not install kdepimlibs4-4.1.3-5.2.6.i586
    install kdepimlibs4-4.2.4-1.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] do not install kde4-kerry-0.2.90-7.15.i586
    
        [ ] Ignore some dependencies of kde4-kerry
    
    
    
    kde4-kget-4.2.4-2.7.i586 requires libplasma.so.3, but this requirement cannot be provided
    uninstallable providers: libkde4-4.2.4.1-2.4.i586[KDE42]
        [ ] Following actions will be done:
    do not install libkde4-4.1.3-4.10.4.i586
    install libkde4-4.2.4.1-2.4.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of kde4-kget
    
        [ ] do not install kde4-kget-4.2.4-2.7.i586
    
    
    
    kde4-ark-4.2.4-1.5.i586 requires kdebase4-runtime >= 4.2.4, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.2.4-2.6.i586[KDE42]
        [ ] Following actions will be done:
    do not install kdebase4-runtime-4.1.3-4.2.9.i586
    install kdebase4-runtime-4.2.4-2.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] do not install kde4-ark-4.2.4-1.5.i586
    
        [ ] Ignore some dependencies of kde4-ark
    
    
    
    kdebase4-runtime-4.2.4-2.6.i586 requires kdelibs4 >= 4.2.4, but this requirement cannot be provided
    uninstallable providers: kdelibs4-4.2.4.1-2.4.i586[KDE42]
        [ ] do not install digikam-0.10.0-5.3.i586
    
        [ ] Ignore some dependencies of kdebase4-runtime
    
        [ ] Following actions will be done:
    do not install kdelibs4-4.1.3-4.10.4.i586
    deinstallation of digikamimageplugins-0.9.4-51.18.i586
    install kdelibs4-4.2.4.1-2.4.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kdepimlibs4-4.2.4-1.5.i586 requires libkdepimlibs4 = 4.2.4, but this requirement cannot be provided
    uninstallable providers: libkdepimlibs4-4.2.4-1.5.i586[KDE42]
        [ ] do not install kde4-kopete-4.2.4-2.7.i586
    
        [ ] Ignore some dependencies of kdepimlibs4
    
        [ ] Following actions will be done:
    do not install libkdepimlibs4-4.1.3-5.2.6.i586
    install libkdepimlibs4-4.2.4-1.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kdelibs4-4.2.4.1-2.4.i586 requires kdelibs4-core = 4.2.4.1, but this requirement cannot be provided
    uninstallable providers: kdelibs4-core-4.2.4.1-2.4.i586[KDE42]
        [ ] do not install PolicyKit-kde-0.2-8.11.i586
    
        [ ] Following actions will be done:
    do not install kdelibs4-core-4.1.3-4.10.4.i586
    install kdelibs4-core-4.2.4.1-2.4.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of kdelibs4
    
    
    
    kdebase4-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-kcalc-4.2.4-1.5.i586
    
        [ ] Ignore some dependencies of kdebase4
    
        [ ] Following actions will be done:
    do not install kdebase4-4.1.3-3.8.9.i586
    install kdebase4-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kde4-kwin-4.1.3-10.3.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Following actions will be done:
    do not install kde4-kwin-4.1.3-10.3.7.i586
    install kde4-kwin-4.2.4-3.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] do not install kde4-kmines-4.2.4-1.5.i586
    
        [ ] Ignore some dependencies of kde4-kwin
    
    
    
    kde4-konqueror-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-konqueror
    
        [ ] do not install kde4-kgamma-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kde4-konqueror-4.1.3-3.8.9.i586
    deinstallation of kde4-konqueror-4.1.3-3.8.9.i586
    
    
    kde4-konsole-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-konsole
    
        [ ] do not install kde4-kio_kamera-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kde4-konsole-4.1.3-3.8.9.i586
    install kde4-konsole-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kde4-kwrite-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-kio_sysinfo-11.1.1-67.5.i586
    
        [ ] Ignore some dependencies of kde4-kwrite
    
        [ ] Following actions will be done:
    do not install kde4-kwrite-4.1.3-3.8.9.i586
    install kde4-kwrite-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kde4-kgreeter-plugins-4.1.3-10.3.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-kmahjongg-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kde4-kgreeter-plugins-4.1.3-10.3.7.i586
    install kde4-kgreeter-plugins-4.2.4-3.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of kde4-kgreeter-plugins
    
    
    
    kde4-kfind-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-kfind
    
        [ ] do not install kde4-kcolorchooser-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kde4-kfind-4.1.3-3.8.9.i586
    install kde4-kfind-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    
    
    kde4-keditbookmarks-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-kdnssd-4.2.4-2.7.i586
    
        [ ] Following actions will be done:
    do not install kde4-keditbookmarks-4.1.3-3.8.9.i586
    install kde4-keditbookmarks-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of kde4-keditbookmarks
    
    
    
    kde4-kdm-4.1.3-10.3.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-kdm
    
        [ ] Following actions will be done:
    do not install kde4-kdm-4.1.3-10.3.7.i586
    install kde4-kdm-4.2.4-3.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] do not install kde4-kio_audiocd-4.2.4-1.6.i586
    
    
    
    kde4-dolphin-4.1.3-3.8.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Following actions will be done:
    do not install kde4-dolphin-4.1.3-3.8.9.i586
    do not install kdebase4-libkonq-4.1.3-3.8.9.i586
    install kde4-dolphin-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    do not install libkonq5-4.1.3-3.8.9.i586
    install kdebase4-libkonq-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
    install libkonq5-4.2.4-1.6.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of kde4-dolphin
    
        [ ] do not install kde4-konqueror-plugins-4.2.4-4.4.i586
    
    
    
    kdebase4-workspace-4.1.3-10.3.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Following actions will be done:
    do not install kdebase4-workspace-4.1.3-10.3.7.i586
    install kdebase4-workspace-4.2.4-3.5.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] do not install kde4-kpat-4.2.4-1.5.i586
    
        [ ] Ignore some dependencies of kdebase4-workspace
    
    
    
    kde4-korganizer-4.1.3-3.14.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Following actions will be done:
    do not install kde4-korganizer-4.1.3-3.14.9.i586
    deinstallation of kde4-korganizer-4.1.3-3.14.9.i586
        [ ] do not install kde4-kgpg-4.2.4-1.5.i586
    
        [ ] Ignore some dependencies of kde4-korganizer
    
    
    
    kde4-kmail-4.1.3-3.14.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-kmail
    
        [ ] do not install kde4-kmix-4.2.4-1.6.i586
    
        [ ] Following actions will be done:
    do not install kde4-kmail-4.1.3-3.14.9.i586
    deinstallation of kde4-kmail-4.1.3-3.14.9.i586
    
    
    kdepim4-4.1.3-3.14.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-kwalletmanager-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kdepim4-4.1.3-3.14.9.i586
    deinstallation of kdepim4-4.1.3-3.14.9.i586
        [ ] Ignore some dependencies of kdepim4
    
    
    
    kdepim4-wizards-4.1.3-3.14.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] do not install kde4-superkaramba-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kdepim4-wizards-4.1.3-3.14.9.i586
    deinstallation of kdepim4-wizards-4.1.3-3.14.9.i586
        [ ] Ignore some dependencies of kdepim4-wizards
    
    
    
    kde4-akregator-4.1.3-3.14.9.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] Ignore some dependencies of kde4-akregator
    
        [ ] Following actions will be done:
    do not install kde4-akregator-4.1.3-3.14.9.i586
    deinstallation of kde4-akregator-4.1.3-3.14.9.i586
        [ ] do not install kde4-krdc-4.2.4-2.7.i586
    
    
    
    #### YaST2 conflicts list END ###
    I could not post all conflicts, cause i can not post attachements and there is limit of message.
    What am i doing wrong? If i ignore all conflict depends? Thx!

  2. #2
    Join Date
    Jan 2009
    Location
    Seoul South Korea
    Posts
    26

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    First I would set all of the priority values of your repositories to 99. Then I would install the yast2-factory and run that to perform the upgrade. I had a rather smooth experience doing it this way.

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Hi,

    Set your update repository to 99, then try it. Give any other conflicts after you do this and we'll settle it out.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    slackma NNTP User

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Ok.
    Ive changed priorities of repos to 99 for all of them.
    Code:
    darkstar:/home/slackman # zypper lr --details
    #  | Alias                 | Name                  | Enabled | Refresh | Priority | Type   | URI                     | Service
    ---+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1  | KDE42                 | KDE42                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/                     |
    2  | KDE42Community        | KDE42Community        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/ |
    3  | Qt44                  | Qt44                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt44/openSUSE_11.1/                   |
    4  | devel:tools:building  | devel:tools:building  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/      |
    5  | openSUSE 11.1-0       | openSUSE 11.1-0       | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/sr0                     |
    6  | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1                     |
    7  | repo-debug            | openSUSE-11.1-Debug   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                     |
    8  | repo-non-oss          | openSUSE-11.1-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                     |
    9  | repo-oss              | openSUSE-11.1-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                     |
    10 | repo-source           | openSUSE-11.1-Source  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/                     |
    11 | repo-update           | openSUSE-11.1-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                     |
    darkstar:/home/slackman #
    Now there are less conflicts... ))) However, they are as following

    Code:
    #### YaST2 conflicts list - generated 2009-06-13 18:04:24 ####
    
    compiz-kde4-0.7.8-9.1.i586 requires libplasma.so.2, but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.1.3-10.1.i586[openSUSE 11.1-0]
                       kdebase4-workspace-4.1.3-10.2.1.i586[openSUSE-11.1-Updates]
                       kdebase4-workspace-4.1.3-10.1.i586[repo-oss]
                       kdebase4-workspace-4.1.3-10.2.1.i586[repo-update]
        [ ] Following actions will be done:
    do not install compiz-kde4-0.7.8-9.1.i586
    downgrade of compiz-kde4-0.7.8-9.1.i586 to compiz-kde4-0.7.8-8.13.i586
    install compiz-kde4-0.7.8-8.13.i586 (with vendor change)
      openSUSE
    -->
      openSUSE Build Service
        [ ] Ignore some dependencies of compiz-kde4
    
        [ ] Following actions will be done:
    do not install kdebase4-workspace-4.2.4-3.5.i586
    do not install kdebase4-workspace-ksysguardd-4.2.4-3.5.i586
    do not install kdebluetooth4-0.3-8.9.i586
    do not install kde4-ark-4.2.4-1.5.i586
    do not install kde4-akregator-4.2.4-2.6.i586
    do not install PolicyKit-kde-0.2-8.11.i586
    do not install kde4-dolphin-4.2.4-1.6.i586
    do not install kde4-kcalc-4.2.4-1.5.i586
    do not install kde4-kaddressbook-4.2.4-2.6.i586
    do not install kde4-kdm-4.2.4-3.5.i586
    do not install kde4-kmines-4.2.4-1.5.i586
    do not install kde4-kgamma-4.2.4-1.5.i586
    do not install kde4-kio_kamera-4.2.4-1.5.i586
    do not install kde4-kmail-4.2.4-2.6.i586
    do not install kde4-kontact-4.2.4-2.6.i586
    do not install kde4-keditbookmarks-4.2.4-1.6.i586
    do not install kde4-kget-4.2.4-2.7.i586
    do not install kde4-konsole-4.2.4-1.6.i586
    do not install kde4-kcolorchooser-4.2.4-1.5.i586
    do not install kde4-kdnssd-4.2.4-2.7.i586
    do not install kde4-kio_audiocd-4.2.4-1.6.i586
    do not install kde4-knotes-4.2.4-2.6.i586
    do not install kde4-kpat-4.2.4-1.5.i586
    do not install kde4-kgpg-4.2.4-1.5.i586
    do not install kde4-kmix-4.2.4-1.6.i586
    do not install kde4-kwrite-4.2.4-1.6.i586
    do not install kde4-superkaramba-4.2.4-1.5.i586
    do not install kde4-korganizer-4.2.4-2.6.i586
    do not install kde4-kreversi-4.2.4-1.5.i586
    do not install kde4-krfb-4.2.4-2.7.i586
    do not install kde4-kscd-4.2.4-1.6.i586
    do not install kde4-ksnapshot-4.2.4-1.5.i586
    do not install kde4-ksudoku-4.2.4-1.5.i586
    do not install kde4-okular-4.2.4-1.5.i586
    do not install kde4-plasma-addons-4.2.4-1.6.i586
    do not install kde4-plasmoid-quickaccess-0.8-3.13.i586
    do not install kdepim4-wizards-4.2.4-2.6.i586
    do not install kdeartwork4-screensaver-4.2.4-1.6.i586
    do not install kdebase4-4.2.4-1.6.i586
    do not install kdepim4-4.2.4-2.6.i586
    do not install skanlite-0.3.kde4.2.4-2.3.i586
    
    
    digikamimageplugins-0.9.4-51.18.i586 requires libdigikam.so.0, but this requirement cannot be provided
    
        [ ] deinstallation of digikamimageplugins-0.9.4-51.18.i586
    
        [ ] do not install digikam-0.10.0-5.3.i586
    
        [ ] Ignore some dependencies of digikamimageplugins
    
    
    
    kde4-amarok-lang-2.0.1.1-2.1.1.i586 requires kde4-amarok = 2.0.1.1, but this requirement cannot be provided
    
        [ ] Following actions will be done:
    deinstallation of kde4-amarok-lang-2.0.1.1-2.1.1.i586
    deinstallation of amarok-yauap-1.4.10-26.2.1.i586
    deinstallation of amarok-xine-1.4.10-26.2.1.i586
        [ ] Following actions will be done:
    do not install amarok-2.1-2.3.i586
    do not install kde4-akregator-4.2.4-2.6.i586
    do not install PolicyKit-kde-0.2-8.11.i586
    do not install kde4-kcalc-4.2.4-1.5.i586
    do not install kde4-kdm-4.2.4-3.5.i586
    do not install kde4-kerry-0.2.90-7.15.i586
    do not install kde4-kgamma-4.2.4-1.5.i586
    do not install kde4-kmail-4.2.4-2.6.i586
    do not install kde4-konqueror-4.2.4-1.6.i586
    do not install kde4-kontact-4.2.4-2.6.i586
    do not install kde4-keditbookmarks-4.2.4-1.6.i586
    do not install kde4-kget-4.2.4-2.7.i586
    do not install kde4-kmahjongg-4.2.4-1.5.i586
    do not install kde4-kdnssd-4.2.4-2.7.i586
    do not install kde4-knotes-4.2.4-2.6.i586
    do not install kde4-kpat-4.2.4-1.5.i586
    do not install kde4-kmix-4.2.4-1.6.i586
    do not install kde4-kwalletmanager-4.2.4-1.5.i586
    do not install kde4-kopete-4.2.4-2.7.i586
    do not install kde4-krdc-4.2.4-2.7.i586
    do not install kde4-krfb-4.2.4-2.7.i586
    do not install kde4-ksnapshot-4.2.4-1.5.i586
    do not install kde4-kwin-4.2.4-3.5.i586
    do not install kde4-plasma-addons-4.2.4-1.6.i586
    do not install kdepim4-wizards-4.2.4-2.6.i586
    do not install kdeartwork4-screensaver-4.2.4-1.6.i586
    do not install kdebluetooth4-0.3-8.9.i586
    do not install kdepim4-4.2.4-2.6.i586
    do not install skanlite-0.3.kde4.2.4-2.3.i586
        [ ] Ignore some dependencies of kde4-amarok-lang
    
    
    
    kde4-gwenview-4.1.3-4.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[openSUSE 11.1-0]
                       kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
        [ ] replacement of kde4-gwenview-4.1.3-4.7.i586 with gwenview-4.2.4-1.5.i586
    
        [ ] Following actions will be done:
    do not install kdebase4-runtime-4.2.4-2.6.i586
    do not install kde4-akregator-4.2.4-2.6.i586
    do not install PolicyKit-kde-0.2-8.11.i586
    do not install kde4-dolphin-4.2.4-1.6.i586
    do not install kde4-kcalc-4.2.4-1.5.i586
    do not install kde4-kdm-4.2.4-3.5.i586
    do not install kde4-kerry-0.2.90-7.15.i586
    do not install kde4-kgamma-4.2.4-1.5.i586
    do not install kde4-kmail-4.2.4-2.6.i586
    do not install kde4-konqueror-4.2.4-1.6.i586
    do not install kde4-kio_sysinfo-11.1.1-67.5.i586
    do not install kde4-kfind-4.2.4-1.6.i586
    do not install kde4-konsole-4.2.4-1.6.i586
    do not install kde4-kcolorchooser-4.2.4-1.5.i586
    do not install kde4-kio_audiocd-4.2.4-1.6.i586
    do not install kde4-knotes-4.2.4-2.6.i586
    do not install kde4-kpat-4.2.4-1.5.i586
    do not install kde4-kmix-4.2.4-1.6.i586
    do not install kde4-kwalletmanager-4.2.4-1.5.i586
    do not install kde4-kopete-4.2.4-2.7.i586
    do not install kde4-krdc-4.2.4-2.7.i586
    do not install kde4-krfb-4.2.4-2.7.i586
    do not install kde4-ksnapshot-4.2.4-1.5.i586
    do not install kde4-kwin-4.2.4-3.5.i586
    do not install kde4-plasma-addons-4.2.4-1.6.i586
    do not install kdepim4-wizards-4.2.4-2.6.i586
    do not install kdeartwork4-screensaver-4.2.4-1.6.i586
    do not install kdebluetooth4-0.3-8.9.i586
    do not install kdepim4-4.2.4-2.6.i586
    do not install skanlite-0.3.kde4.2.4-2.3.i586
        [ ] Ignore some dependencies of kde4-gwenview
    
    
    
    
    #### YaST2 conflicts list END ###
    As i understand, there are
    1)gwenview - ok, i can live without it.
    2)amarok-lang - ok, too.
    3)digikamimageplugins, ok too
    4)compiz-kde4 - this is questionable for me now... is it ok? does compiz consist in 4.2? what if i switch to do not install it?

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    only your update repo needed to be switched to 99. The others were fine before...

    [X] Following actions will be done:
    do not install compiz-kde4-0.7.8-9.1.i586
    downgrade of compiz-kde4-0.7.8-9.1.i586 to compiz-kde4-0.7.8-8.13.i586
    install compiz-kde4-0.7.8-8.13.i586 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service

    It shouldn't break compiz, but if it does you can always reinstall it.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Sorry haha forgot the rest of them,

    [x] do not install digikam-0.10.0-5.3.i586

    [x] Following actions will be done:
    deinstallation of kde4-amarok-lang-2.0.1.1-2.1.1.i586
    deinstallation of amarok-yauap-1.4.10-26.2.1.i586
    deinstallation of amarok-xine-1.4.10-26.2.1.i586

    [x] replacement of kde4-gwenview-4.1.3-4.7.i586 with gwenview-4.2.4-1.5.i586

    Now you should be good.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    slackma NNTP User

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Thank you too much! ))))
    It works and im using KDE 4.2

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Well done mate. Thanks to Ian for walking you through it.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: KDE 4.1 to 4.2 in OpenSuse 11.1

    Not sure why you keep suggesting yast2-factory this is not recommended as it contains the unstable packages

    Geoff
    Quote Originally Posted by TimButterworth View Post
    First I would set all of the priority values of your repositories to 99. Then I would install the yast2-factory and run that to perform the upgrade. I had a rather smooth experience doing it this way.
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •