Results 1 to 5 of 5

Thread: regarding SSL on Apache

  1. #1

    Default regarding SSL on Apache

    Dear All,

    Please help me to restart the apache2 becasue i am try it with ssl support. I get the following error

    Syntax error on line 108 of /etc/apache2/default-server.conf:
    SSLCipherSuite takes one argument, Colon-delimited list of permitted SSL Ciphers (`XXX:...XX' - see manual)

    here is what i have pasted in /etc/apache2/default-server.conf

    SSLEngine on
    SSLCipherSuite
    ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
    SSLCertificateFile /etc/apache2/ssl.crt/server.crt
    SSLCertificateKeyFile /etc/apache2/ssl.key/server.key


    Regards,
    Ghulam Yaseen
    Best Regards,
    Ghulam Yaseen

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: regarding SSL on Apache

    Code:
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
    You have a space there, in the SSLv2. Just copy paste my line to your configuration and make sure you don't accidentally "cut the line".

  3. #3
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: regarding SSL on Apache

    Code:
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSL v2:+EXP:+eNULL
    The error message says that this should be in one line. But, I am not sure about the actual string you passed is correct or not because it doesn't look like valid SSL Cipher Suite string.
    May be, you can just say something like follows to support ALL.
    Code:
    SSLCipherSuite ALL
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  4. #4

    Default Re: regarding SSL on Apache

    Dear All,

    I have put the following lines into default-server.conf

    SSLEngine on
    SSLCipherSuite ALL
    SSLCertificateFile /etc/apache2/ssl.crt/server.crt
    SSLCertificateKeyFile /etc/apache2/ssl.key/server.key

    I have following error

    testing:/etc/apache2 # rcapache2 restart
    Syntax OK
    Starting httpd2 (prefork) startproc: exit status of parent of /usr/sbin/httpd2-prefork: 1
    failed

    Regards,
    Ghulam Yaseen
    Quote Originally Posted by syampillai View Post
    Code:
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSL v2:+EXP:+eNULL
    The error message says that this should be in one line. But, I am not sure about the actual string you passed is correct or not because it doesn't look like valid SSL Cipher Suite string.
    May be, you can just say something like follows to support ALL.
    Code:
    SSLCipherSuite ALL
    Best Regards,
    Ghulam Yaseen

  5. #5

    Default Re: regarding SSL on Apache

    I think I set apache up properly (I have done so in the past). But it
    is not working. It claims that the ports are in use, but they don't seem to be:
    jarfx:/var/log/apache2 # netstat -tan
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address
    State
    tcp 0 0 0.0.0.0:9090 0.0.0.0:*
    LISTEN
    tcp 0 0 127.0.0.1:9092 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:901 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:9000 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:*
    LISTEN
    tcp 0 0 127.0.0.1:631 0.0.0.0:*
    LISTEN
    tcp 0 0 127.0.0.1:25 0.0.0.0:*
    LISTEN
    tcp 0 0 127.0.0.1:6010 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:3483 0.0.0.0:*
    LISTEN
    tcp 0 0 0.0.0.0:17500 0.0.0.0:*
    LISTEN
    tcp 38 0 192.168.1.9:43503 208.43.223.179:443
    CLOSE_WAIT
    tcp 0 0 127.0.0.1:9092 127.0.0.1:43189
    ESTABLISHED
    tcp 0 0 192.168.1.9:22 192.168.1.11:50218
    ESTABLISHED
    tcp 0 0 192.168.1.9:36559 174.36.30.48:80
    ESTABLISHED
    tcp 38 0 192.168.1.9:57342 204.236.220.71:443
    CLOSE_WAIT
    tcp 0 0 192.168.1.9:3483 192.168.1.20:45622
    ESTABLISHED
    tcp 0 0 127.0.0.1:43189 127.0.0.1:9092
    ESTABLISHED
    tcp 38 0 192.168.1.9:59716 174.36.30.90:443
    CLOSE_WAIT
    tcp 0 0 192.168.1.9:3483 192.168.1.6:23337
    ESTABLISHED
    tcp 0 0 192.168.1.9:58324 174.36.30.70:443
    ESTABLISHED
    tcp 0 0 :::139 :::*
    LISTEN
    tcp 0 0 :::111 :::*
    LISTEN
    tcp 0 0 :::22 :::*
    LISTEN
    tcp 0 0 ::1:631 :::*
    LISTEN
    tcp 0 0 ::1:25 :::*
    LISTEN
    tcp 0 0 ::1:6010 :::*
    LISTEN
    tcp 0 0 :::445 :::*
    LISTEN
    tcp 0 0 192.168.1.9:445 192.168.1.11:50132
    ESTABLISHED

    And then
    jarfx:/var/log/apache2 # rcapache2 start
    Starting httpd2 (prefork) (98)Address already in use: make_sock: could
    not bind to address [::]:443
    (98)Address already in use: make_sock: could not bind to address
    0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    startproc: exit status of parent of /usr/sbin/httpd2-prefork: 1

    The unable to open logs points to a permissions issue.

    I uninstalled apache, deleted /etc/apache2, and /etc/sysconfig/
    apache2, and reinstalled and reconfigured, and it still will not work.
    I would love some sugestions.

    Thanks,
    Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •