I recommend You to use KDE 4.2 which is said to be more stable than the one supplied by 11.1