Results 1 to 6 of 6

Thread: Qtcurve without KDE?

  1. #1

    Default Qtcurve without KDE?

    I use Gnome (I've never got on with KDE and its excess of options, plus most apps I like are Gnome-centric) but I've started using a few KDE apps.

    It isn't too bad for VirtualBox, which seems to be using Qt4 and something very nearly identical to my GTK theme. Recently I've also started using eSVN (I was using RapidSVN, but I'm trying to cut down on the number of repositories I have), which looks ugly because it is compiled against Qt3.

    I've found the Qt3 "Qt Configuration", but none of the pre-existing themes are great. I've found QtCurve but it seems to need various KDE libraries, which seems rather excessive for a theme.

    Is there any way to theme Qt3 apps like my GTK apps without hauling in half of KDE while I'm at it?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,059
    Blog Entries
    14

    Default Re: Qtcurve without KDE?

    I don't think so. KDE3 apps are built against qt3, and that is taking care of what things look like. Gnome apps are built against GTK and that's themable to look like qt4 in KDE4 or qt3 (f.e. Qtcurve). Since the Desktops are not a bunch of programs but an integrated desktop environment, it is very likely that you need at least some basic files and libs to use features from that DE.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Qtcurve without KDE?

    I've got Qt4 apps installed without large chunks of KDE, just not Qt3 themes. Qt is a toolkit and it has its own configurator (/usr/lib64/qt3/bin/qtconfig for Qt3), so the desktop environment shouldn't be tied in to it (unless someone has done a "lazy" build and linked to KDE because it was the easiest way to do it).

    As I said, I've got a reasonable looking theme for Qt4 apps, just not for Qt3 apps, and trying to install a Qt3 theme seems to want KDE.

  4. #4

    Default Re: Qtcurve without KDE?

    I just realised that I said I was using KDE apps - I'm not, I'm using Qt apps in Gnome.

    I thought I'd found a solution by ditching the Qt3 app and installing an alternative that uses Qt4 (and so looks more at home in a GTK environment) but I might just be finding out that while the multi-projects feature of QSvn is a great improvement over eSVN, there may be other features that are lacking.

  5. #5

    Default Re: Qtcurve without KDE?

    It looks like what I might need is Polymer v0.3, since it looks fairly close to a Clearlooks theme (or at least "not hideously ugly"). Unfortunately I can't compile it. I've got qt3-devel install, but ./configure bails with:
    Code:
    ...
    checking for Qt root directory... /usr/lib/qt3
    checking for multithreaded Qt3 library... no
    checking for moc... /usr/lib/qt3/bin/moc
    checking for uic... /usr/lib/qt3/bin/uic
    checking for lupdate... no
    checking for lrelease... no
    checking if a small Qt program runs... no
    configure: error: Qt library not found
    Anyone know what's happening? qt3 and qt3-devel are definitely installed since it is picking them up and eSVN is using them, but the configure script can't find something.

  6. #6

    Default Re: Qtcurve without KDE?

    Problem solved by reading more.

    It turns out that although QtCurve pulls in a KDE dependency, it is only a tiny one that isn't the core libs! I've now got Plastik for my Qt3 theme and, while not perfect, it looks a lot better

    Now to remove all of that "devel" junk I had to pull in to try to build Polymer!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •