Results 1 to 7 of 7

Thread: can't install mplayer

  1. #1

    Default can't install mplayer

    Code:
     zypper install mplayer
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libdirectfb-1.1.so.0 needed by MPlayer-1.0rc2_r29116-2.pm.2.i586
     Solution 1: do not ask to install a solvable providing MPlayer
    
    Choose the above solution using '1' or cancel using 'c' [1/C]:

  2. #2
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: can't install mplayer

    DirectFB should be available on the openSUSE 11.1 dvd.

  3. #3

    Default Re: can't install mplayer

    there is

    DirectFB - graphics library for framebuffer devices

    installed but still cant install mplayer

  4. #4

    Default Re: can't install mplayer

    post your repos list

    zypper lr

  5. #5
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: can't install mplayer

    Need to install package DirectFB
    Available in openSUSE DVD and at the repo.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  6. #6

    Default Re: can't install mplayer

    Code:
    #  | Alias           | Name                  | Enabled | Refresh
    ---+-----------------+-----------------------+---------+--------
    1  | gnome           | gnome                 | Yes     | Yes    
    2  | gnome2          | gnome2                | Yes     | Yes    
    3  | openSUSE 11.1-0 | openSUSE 11.1-0       | Yes     | No     
    4  | packman         | packman               | Yes     | Yes    
    5  | repo-debug      | openSUSE-11.1-Debug   | No      | Yes    
    6  | repo-non-oss    | openSUSE-11.1-Non-Oss | Yes     | Yes    
    7  | repo-oss        | openSUSE-11.1-Oss     | Yes     | Yes    
    8  | repo-source     | openSUSE-11.1-Source  | No      | Yes    
    9  | repo-update     | openSUSE-11.1-Update  | Yes     | Yes    
    10 | vlc             | vlc                   | Yes     | Yes    
    11 | wine            | wine                  | Yes     | Yes

  7. #7

    Default Re: can't install mplayer

    it seems Packman has compiled MPlayer with an older version of DirectFB. Currently included version of DirectFB provides libdirectfb-1.2.so.0 and NOT libdirectfb-1.1.so.0

    Either contact the packman packager of MPlayer or compile MPlayer yourself which is not that difficult

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •