Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Zimbra Desktop

  1. #1
    jdplunkett89 NNTP User

    Default Zimbra Desktop

    I'm having an issue installing Zimbra Desktop. I've downloaded it from the website it goes to do the install using gedit I get this:

    "Could not open the file /tmp/zdesktop_1_0_build_1593_linux_i686.sh.

    gedit has not been able to detect the character coding.
    Please check that you are not trying to open a binary file.
    Select a character coding from the menu and try again."

    Anyone have any suggestions, please?

  2. #2
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Zimbra Desktop

    >
    > I'm having an issue installing Zimbra Desktop. I've downloaded it from
    > the website it goes to do the install using gedit I get this:
    >
    > "Could not open the file /tmp/zdesktop_1_0_build_1593_linux_i686.sh.
    >
    > gedit has not been able to detect the character coding.
    > Please check that you are not trying to open a binary file.
    > Select a character coding from the menu and try again."
    >
    > Anyone have any suggestions, please?


    A bit more information would be helpful.
    How did you execute the file? What user account were you using? It may
    require root. Did you follow the readme for Zimbra Desktop? What version of
    SuSE are you running? What desktop? KDE or GNOME?




  3. #3
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Zimbra Desktop

    jdplunkett89 adjusted his/her AFDB on Wednesday 10 Jun 2009 19:06 to write:

    >
    > I'm having an issue installing Zimbra Desktop. I've downloaded it from
    > the website it goes to do the install using gedit I get this:


    Why is it trying to install using an editor?

    You should install that by in a console as root issuing something like

    cd /tmp/

    sh ./zdesktop_1_0_build_1593_linux_i686.sh.

    Now it should run, however I have not read the install instruction for this
    but you might also have to change it so that it is executable

    Personally I would copy it to another dir first, maybe your home first as if
    you have clear tmp set on the system it might get deleted on next boot.


    >
    > "Could not open the file /tmp/zdesktop_1_0_build_1593_linux_i686.sh.
    >
    > gedit has not been able to detect the character coding.
    > Please check that you are not trying to open a binary file.
    > Select a character coding from the menu and try again."


    The reason is that your machine looks at the .sh and thinks it is a text
    script and so tries to open it with an editor.

    >
    > Anyone have any suggestions, please?
    >
    >

    HTH
    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Zimbra Desktop

    > You should install that by in a console as root issuing something like

    You should not install as root, in fact it will warn about this. Just use
    your user account.

    You do need to chmod +x on the file after downloading it.

    > sh ./zdesktop_1_0_build_1593_linux_i686.sh.


    I just ran the installer and while it does blather a lot of errors and
    warnings in the konsole window, the install does work.


  5. #5
    jdplunkett89 NNTP User

    Default Re: Zimbra Desktop

    Here's what all I have done:

    1) Went to the Zimbra website using FireFox 3.
    2) Clicked the download button on the website and it started the download using the FireFox download manager.
    3) Then the error occurs directly after the download completes. It automatically brings up the screen with that error that I stated previously.

    I am using root, I am running openSuse 11.1, and I am running Gnome desktop. I'm still not having any luck. I've gone into terminal and logged in as root there and typed in "cd /tmp/" and then attempted this step: sh ./zdesktop_1_0_build_1593_linux_i686.sh. from baskitcaise's post but that gets me no where. It says "sh: ./zdesktop_1_0_build_1539_linux_i686.sh: No such file or directory"

  6. #6
    jdplunkett89 NNTP User

    Default Re: Zimbra Desktop

    chmod +x the file? Apologies for the lack of understanding.

  7. #7
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Zimbra Desktop

    It sounds like you are not even getting the download or you are getting it
    and we don't know where it is.

    I'm not a GNOME person so I don't know if it is attempting to automagically
    do a 'run from location' or something like that.

    Try this. Download the file again but tell it where to put it.
    In Firefox go to Edit>Preferences. Make sure you are on the Main settings
    page and find the radio button that says Always ask me where to save files.
    Select it and close.

    Go to Zimbra site and download the file.
    Save it to somewhere like /home/myaccount/Downloads

    Then once you have it downloaded, open a Terminal window.

    go into the Downloads directory /home/myaccount/Downloads
    type chmod +x zdesktop_1_0_build_1539_linux_i686.sh

    then do a
    ../zdesktop_1_0_build_1539_linux_i686.sh

    It should run and install. You do not need to be root. There are many
    prompts to go through. I'd just take the defaults.






  8. #8
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Zimbra Desktop

    The next thing you will likely want, assuming the installer behaves on
    GNOME as it does on KDE, is you will want to know how to launch the thing
    after you exit it for the first time since it doesn't build an icon into the
    'Start Menu'. Your first reaction would be to run zdesktop in the root of
    the zimbra directory. That would be wrong and it won't work. Use a file
    manager like Nautilus in GNOME to browse to:

    /home/user/zimbra/zdesktop/linux

    and execute the file in there:

    linux.desktop

    You can build your own Menu item icon or drag a copy of it to your toolbar.


  9. #9
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Zimbra Desktop

    GofBorg adjusted his/her AFDB on Wednesday 10 Jun 2009 19:55 to write:

    >> You should install that by in a console as root issuing something like

    >
    > You should not install as root, in fact it will warn about this. Just use
    > your user account.



    Thanx for clearing that G, I have not seen this installer so just went with
    a standard response.


    --
    Mark

    Nullus in verba
    Nil illegitimi carborundum

  10. #10

    Default Re: Zimbra Desktop

    Well reading about Zimbra Desktop, i thougth of installing and checking it out.

    1. Downloaded file to /home/<user>/download folder
    2. in Dolphin, navigate to the folder and right click on the file & select properties.
    3. In properties window, select permission tab and check is executable box. say ok and close window
    4. double click on file. Installer starts.
    5. the installer puts a shortcut on the desktop.

    now to see how it works.

    Cheers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •